Bug 526789 - Install didn't reboot at the end
Install didn't reboot at the end
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F12AnacondaBlocker
  Show dependency treegraph
 
Reported: 2009-10-01 15:10 EDT by Alexey Torkhov
Modified: 2009-11-02 19:27 EST (History)
9 users (show)

See Also:
Fixed In Version: anaconda-13.7-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-02 19:27:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (128.19 KB, text/plain)
2009-10-01 15:10 EDT, Alexey Torkhov
no flags Details
program.log (11.01 KB, text/plain)
2009-10-01 15:11 EDT, Alexey Torkhov
no flags Details
storage.log (209.24 KB, text/plain)
2009-10-01 15:12 EDT, Alexey Torkhov
no flags Details

  None (edit)
Description Alexey Torkhov 2009-10-01 15:10:30 EDT
Created attachment 363387 [details]
anaconda.log

Description of problem:
Anaconda claims that it finished the install and asked for reboot. I confirmed, but it didn't reboot.

Version-Release number of selected component (if applicable):
anaconda-12.32-1.fc12.i686
Comment 1 Alexey Torkhov 2009-10-01 15:11:40 EDT
Created attachment 363388 [details]
program.log
Comment 2 Alexey Torkhov 2009-10-01 15:12:07 EDT
Created attachment 363390 [details]
storage.log
Comment 3 Hans de Goede 2009-10-01 16:56:33 EDT
Hmm,

The logs look like you did a livecd install, is that correct?
Comment 4 Alexey Torkhov 2009-10-01 17:01:22 EDT
Right, livecd install.
Comment 5 Alexey Torkhov 2009-10-01 17:34:29 EDT
Perhaps it rightly didn't reboot, as bootloader wasn't installed - bug# 526822.
Comment 6 Chris Lumens 2009-10-02 10:27:12 EDT
When you say "didn't reboot", do you mean that you tried to ctrl-alt-del or pressed the reboot button when anaconda was done and that anaconda never went away, or that the machine started to reboot and stopped because the bootloader was misconfigured?

Basically, did anaconda leave the screen and you go back through the BIOS startup or not?
Comment 7 Alexey Torkhov 2009-10-02 10:32:07 EDT
I pressed reboot button in anaconda, it closes its window and leaves me in gnome session.
Comment 8 James Laska 2009-10-13 16:59:23 EDT
I think this is more an issue that the installer presents a button on the final "Congratulations" step that says [Reboot].  Which doesn't make sense during a live install.

I could have sworn this button used to say "Exit" for live installs.  I could be making that up though.
Comment 9 Chris Lumens 2009-10-15 09:33:47 EDT
James - you are correct.  It should say "Exit" instead of "Reboot".  That's the bug here.
Comment 10 James Laska 2009-10-26 18:07:53 EDT
Clumens, this is fixed in F-13, not F-12 right?
Comment 11 David Cantrell 2009-10-26 23:45:19 EDT
(In reply to comment #10)
> Clumens, this is fixed in F-13, not F-12 right?  

Yes, F-13, not F-12.  We're using the 'Fixed in version' field to note the release of anaconda that will include the fix.  The major version number of anaconda aligns with the Fedora release, so anaconda-13.x will be F-13.
Comment 12 James Laska 2009-10-27 11:19:02 EDT
Thanks David, sorry ... wasn't seeing the 'fixed in version' field.  I'd support taking this fix into f12-branch.  While it's certainly by no means a high severity issue, I think it's more a polish bug where people will be filing more bugs as they're expecting 'reboot' behavior.  

Additionally, The patch [1] seems non-invasive and only affects the conditional used to determine which button to present (iw/congrats_gui.py) and the zz-liveinst.sh script used to write out a $HOME/Desktop/liveinst.desktop icon (which is already being called due to the fallback else condition).

I've discussed cherry-picking this patch into f12-branch.  I'm raising this for inclusion into F12 by adding blocks:F12Blocker.

[1] http://git.fedorahosted.org/git/?p=anaconda.git;a=commit;h=be0ed2274bda569f960ce91350b2fb57f8e36f3c
Comment 13 jmccann 2009-10-29 16:22:33 EDT
FWIW, I don't think Exit is a very good choice.  "Quit" is much better.  However, since the install is done at that point probably keeping Reboot (without the icon) button and actually doing a reboot in response to it is best.
Comment 14 David Cantrell 2009-10-29 20:09:11 EDT
I went ahead and pulled over clumens' patch from master and committed it to f12-branch.

Will be fixed in anaconda-12.42-1.
Comment 15 Adam Williamson 2009-10-31 00:54:43 EDT
this is in the 12.42 build:

http://koji.fedoraproject.org/koji/buildinfo?buildID=139122

tag request:

https://fedorahosted.org/rel-eng/ticket/2942

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 16 Bill Nottingham 2009-11-02 16:18:46 EST
This should be in tomorrow's (20091103) rawhide; please test that.
Comment 17 Adam Williamson 2009-11-02 19:27:13 EST
This is fixed. With anaconda from F12 Beta live image, the final button says Reboot. With the same image, but updating anaconda to 12.42 before running the install process, the final button says Close.

Closing the bug, please re-open if anyone sees any trouble here.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.