Bug 526824 - Configuring Kerberos for Firefox is ugly
Summary: Configuring Kerberos for Firefox is ugly
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: firefox
Version: 5.3
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Gecko Maintainer
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-01 21:18 UTC by Dmitri Pal
Modified: 2009-10-05 23:38 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2009-10-05 23:38:30 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 520668 None None None Never

Description Dmitri Pal 2009-10-01 21:18:09 UTC
Description of problem:

To be able to use FF with kerberos SSO one has to follow the instructions like this: 
Firefox can use your Kerberos credentials for authentication, but you need to specify which domains to communicate with, and using which attributes.

1. Open Firefox, and type "about:config" in the Address Bar.
2. In the Search field, type "negotiate".
3. Ensure the following lines reflect your setup. Replace ".example.com" with your own kerberos domain, including the preceding period (.):

      network.negotiate-auth.trusted-uris  .example.com
      network.negotiate-auth.delegation-uris  .example.com
      network.negotiate-auth.using-native-gsslib true

4. If you are configuring Firefox on Microsoft Windows, make the following changes instead:

      network.negotiate-auth.trusted-uris  .example.com
      network.auth.use-sspi false
      network.negotiate-auth.delegation-uris  .example.com

5. In Firefox, navigate to the kerberos protected web site and ensure that there are no Kerberos authentication errors, and that you can see and interact with the web site. 

This bug is a request to provide a much more user friendly way of accomplishing the same goal using some kind of click through interface. It should also be possible to configure it using system management tools and scripts. 

Version-Release number of selected component (if applicable):
Any

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Matěj Cepl 2009-10-05 23:38:30 UTC
Completely agree, we filed this bug in the upstream database (https://bugzilla.mozilla.org/show_bug.cgi?id=520668) because we believe that it is more appropriate to let it be resolved upstream.

We will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

Thank you for the bug report.


Note You need to log in before you can comment on or make changes to this bug.