Bug 526833 - prelinking octave causes it to segfault
Summary: prelinking octave causes it to segfault
Keywords:
Status: CLOSED DUPLICATE of bug 524493
Alias: None
Product: Fedora
Classification: Fedora
Component: prelink
Version: rawhide
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-01 22:44 UTC by Orion Poplawski
Modified: 2009-10-27 17:25 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-27 17:25:21 UTC
Type: ---


Attachments (Terms of Use)

Description Orion Poplawski 2009-10-01 22:44:03 UTC
Description of problem:

After freshly installing octave, it runs okay.  After prelink runs it segfaults immediately on startup.

Version-Release number of selected component (if applicable):
prelink-0.4.2-3.fc12.x86_64
octave-3.2.2-5.fc12.x86_64

How reproducible:
Everytime

(gdb) run
Starting program: /usr/bin/octave
[Thread debugging using libthread_db enabled]

Program received signal SIGSEGV, Segmentation fault.
__static_initialization_and_destruction_0 (this=0xd13090) at MDiagArray2.cc:51
51      template <class T> MDiagArray2<T> MDiagArray2<T>::nil_array;
Current language:  auto
The current source language is "auto; currently c++".
Missing separate debuginfos, use: debuginfo-install arpack-2.1-12.fc12.x86_64 atlas-3.8.3-10.fc12.x86_64 blas-3.2.1-3.fc12.x86_64 fftw-3.2.1-3.fc12.x86_64 freetype-2.3.9-6.fc12.x86_64 ftgl-2.1.3-0.2.rc5.fc12.x86_64 hdf5-1.8.3-2.fc12.x86_64 libX11-1.2.99-5.20090805.fc12.x86_64 libXau-1.0.5-1.fc12.x86_64 libXdamage-1.1.1-9.fc12.x86_64 libXext-1.0.99.4-3.fc12.x86_64 libXfixes-4.0.3-8.fc12.x86_64 libXxf86vm-1.0.99.1-1.fc12.x86_64 libdrm-2.4.14-1.fc12.x86_64 libgcc-4.4.1-17.x86_64 libgfortran-4.4.1-17.x86_64 libstdc++-4.4.1-17.x86_64 libxcb-1.4-1.fc12.x86_64 mesa-libGL-7.6-0.13.fc12.x86_64 mesa-libGLU-7.6-0.13.fc12.x86_64 ncurses-libs-5.7-3.20090207.fc12.x86_64 pcre-7.8-3.fc12.x86_64 qrupdate-1.0.1-2.fc12.x86_64 readline-6.0-3.fc12.x86_64 suitesparse-3.4.0-2.fc12.x86_64 zlib-1.2.3-23.fc12.x86_64
(gdb) bt
#0  0x00000030014691be in __static_initialization_and_destruction_0 (this=0xd13090)
   from /usr/lib64/octave-3.2.2/liboctave.so
#1  global constructors keyed to MArray_s.cc(void) (this=0xd13090) at MArray-s.cc:48
#2  0x0000003001965636 in __do_global_ctors_aux ()
   from /usr/lib64/octave-3.2.2/liboctave.so
#3  0x000000300118aefb in _init () from /usr/lib64/octave-3.2.2/liboctave.so
#4  0x00007fff9cbe0b48 in ?? ()
#5  0x0000003cf100ebc9 in call_init (l=0x7fa70af7c000, argc=30417600,
    argv=0x7fff9cbe0b38, env=0x7fff9cbe0b48) at dl-init.c:70
#6  0x0000003cf100ed4f in _dl_init (main_map=0x3cf12210e8, argc=1,
    argv=0x7fff9cbe0b38, env=0x7fff9cbe0b48) at dl-init.c:134
#7  0x0000003cf1000b2a in _dl_start_user () from /lib64/ld-linux-x86-64.so.2
#8  0x0000000000000001 in ?? ()
#9  0x00007fff9cbe1f6a in ?? ()
#10 0x0000000000000000 in ?? ()

I've got no idea where to start.

Comment 1 Orion Poplawski 2009-10-01 22:57:02 UTC
(gdb) up
#1  global constructors keyed to MArray_s.cc(void) (this=0xd13090) at MArray-s.cc:48
46      template class OCTAVE_API MDiagArray2<short>;
47
48      INSTANTIATE_MDIAGARRAY2_FRIENDS (short, OCTAVE_API)

Comment 2 Michal Schmidt 2009-10-27 17:25:21 UTC

*** This bug has been marked as a duplicate of bug 524493 ***


Note You need to log in before you can comment on or make changes to this bug.