Bug 526836 - firstboot appears to be confused with multiple monitor setup
firstboot appears to be confused with multiple monitor setup
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs
: 529045 (view as bug list)
Depends On:
Blocks: F12Blocker/F12FinalBlocker
  Show dependency treegraph
 
Reported: 2009-10-01 20:00 EDT by Dave Airlie
Modified: 2013-01-10 00:30 EST (History)
5 users (show)

See Also:
Fixed In Version: firstboot-1.110-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-21 17:41:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dave Airlie 2009-10-01 20:00:03 EDT
Since ajax set X to start by default spanning monitors it seems firstboot
is confused, not sure exactly why.

I appeared to get a window with the button offscreen somewhere, however
X then crashed when I vt switched (different bug, fixed in rawhide) so I didn't get much further.

We probably need to investigate this before beta or final.
Comment 1 Dave Airlie 2009-10-01 20:01:50 EDT
Okay some more info the app appears to be confused with xinerama geometries or something, it starts on the right hand screen, but looks to be sized for the left or something like that.
Comment 2 Adam Williamson 2009-10-14 14:43:45 EDT
*** Bug 529045 has been marked as a duplicate of this bug. ***
Comment 3 Adam Williamson 2009-10-14 14:44:48 EDT
see my duplicate for a more extensive evaluation.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Adam Williamson 2009-10-14 17:53:49 EDT
this Koji build with the elsewhere-discussed 'ui fixes':

http://koji.fedoraproject.org/koji/buildinfo?buildID=136672

makes it usable in my problematic case. I have asked Robert Day to see if it does anything about his. Dave, does it sort out yours too?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Adam Williamson 2009-10-14 18:22:06 EDT
jesse wants to add this post-beta rather than try to cram it into the beta, so dropping the beta blocker designation. will document on Common Bugs.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Adam Williamson 2009-10-15 14:02:59 EDT
oh, forgot to mention - Robert Day reported the updated firstboot fixes his instance of the bug too, which is great, more than I expected in fact. can we file a request to have this tagged into f12 final (not beta)?

common bugs: https://fedoraproject.org/wiki/Common_F12_bugs#firstboot-multihead

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Vedran Miletić 2009-10-18 07:32:46 EDT
I can think of another problematic case for spanned firstboot. On RV730 and RV740 GPUs (Radeon 46xx and 47xx) and maybe some other, default order of displays is swapped on opensource ATI drivers compared to ATI Catalyst.

To explain it a bit better, consider this: if you connect left monitor to lower port, and right monitor to upper port on card, and install ATI Catalyst under Windows, you will get (by default) right order of displays.

However, when using opensource (either radeon or radeonhd) drivers, it will be swapped. That means firstboot will look a bit weird, even if it's fully functional.

I'm not sure if there is a bug about it (on xorg-video-ati or xorg-video-radeonhd); I never considered reporting it because it is so easy to reconfigure, but since user can't configure displays before firstboot appears, it will indeed look a bit weird.
Comment 8 Jesse Keating 2009-10-21 17:41:59 EDT
The build is tagged for final.

Note You need to log in before you can comment on or make changes to this bug.