Bug 526867 - libdevmapper lacks API documentation
libdevmapper lacks API documentation
Status: NEW
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
23
All Linux
low Severity medium
: ---
: ---
Assigned To: Alasdair Kergon
Fedora Extras Quality Assurance
: Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-02 04:20 EDT by Hans de Goede
Modified: 2015-12-14 19:36 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-18 06:59:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2009-10-02 04:20:37 EDT
libdevmapper install a public header and is used by several other
pieces of software, yet completely lacks any API documentation.

As a minimum some comments in the public header files describing the
functions would be very nice to have.
Comment 1 Alasdair Kergon 2009-10-02 07:14:11 EDT
Well I wouldn't go so far as to say 'completely lacks', but there's certainly room to add some references and improve it.  Newer parts of the file are well-documented, but the core section presupposes an understanding of the kernel's device-mapper interface e.g. from the dmsetup man page, the kernel header linux/dm-ioctl.h or the middle section of http://people.redhat.com/agk/talks/FOSDEM_2005/ .
Comment 2 Bug Zapper 2009-11-16 08:11:34 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Fedora End Of Life 2013-04-03 15:58:30 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 19 development cycle.
Changing version to '19'.

(As we did not run this process for some time, it could affect also pre-Fedora 19 development
cycle bugs. We are very sorry. It will help us with cleanup during Fedora 19 End Of Life. Thank you.)

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora19
Comment 4 Vratislav Podzimek 2014-06-30 05:03:59 EDT
Any progress here?
Comment 5 Zdenek Kabelac 2014-06-30 05:23:51 EDT
Not much, since the complexity of usage of device mapper is quite high - it's currently much better for users to stay with  'dmsetup'/'lvm' commands.
Comment 6 Fedora End Of Life 2015-01-09 16:40:43 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 7 Vratislav Podzimek 2015-01-12 05:35:08 EST
Still the same on F21: device-mapper-libs-1.02.90-1.fc21.x86_64
Comment 8 Fedora End Of Life 2015-02-18 06:59:56 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 9 Vratislav Podzimek 2015-02-18 10:05:05 EST
Still the same even on F22.
Comment 10 Ian Pilcher 2015-12-14 19:36:44 EST
Still the same on F23.

Note You need to log in before you can comment on or make changes to this bug.