Bug 526899 - Encrypted partitions has "Unknown" type in table and ext4 in editor
Encrypted partitions has "Unknown" type in table and ext4 in editor
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12Blocker/F12FinalBlocker F12Beta/F12BetaBlocker
  Show dependency treegraph
 
Reported: 2009-10-02 08:49 EDT by Alexey Torkhov
Modified: 2009-10-14 14:34 EDT (History)
6 users (show)

See Also:
Fixed In Version: anaconda-12.37-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-14 14:34:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot (129.50 KB, image/png)
2009-10-02 09:24 EDT, Alexey Torkhov
no flags Details

  None (edit)
Description Alexey Torkhov 2009-10-02 08:49:03 EDT
Description of problem:
I changed existing PV encryption status and it becomes to have "Unknown" type in table.

Version-Release number of selected component (if applicable):
anaconda-12.32-1.fc12.i686
Comment 1 Alexey Torkhov 2009-10-02 08:51:48 EDT
Editing encrypted PV again shows "ext4" fs type in editor.
Comment 2 Alexey Torkhov 2009-10-02 09:08:11 EDT
Logs in bug# 526906, if needed.
Comment 3 Alexey Torkhov 2009-10-02 09:10:00 EDT
And it doesn't have "encrypt" checkbox set.
Seems, same happens with all other partition types.
Comment 4 Alexey Torkhov 2009-10-02 09:24:24 EDT
Created attachment 363477 [details]
Screenshot

Screenshot of what happened when I changed encrypt status of swap partition.
Comment 5 Joel Andres Granados 2009-10-02 10:11:31 EDT
Does this happen with preexisting LVM only?  I just performed the following test:

1. created VG
2. created 2 LV (no encryption)
3. modified one LV (checked encryption)
4. modified the previous LV (unchecked encryption)

I did not see "unknown" anywhere in the custom layout.
Comment 6 Alexey Torkhov 2009-10-02 10:22:20 EDT
That is on kvm virtual guest with new clean disk image.
I started with default partitioning and just click encrypt on swap.
Also, this is on livecd, as you see on screenshot.
Comment 7 Alexander Todorov 2009-10-02 12:26:28 EDT
Can't reproduce with Xen and regular install. I'll have to check the LiveCD and KVM tomorrow.
Comment 8 Chris Lumens 2009-10-05 09:24:20 EDT
Any luck reproducing?
Comment 9 Alexey Torkhov 2009-10-05 11:58:03 EDT
I'm still seeing this error with newer livecd.
But question was to Alexander Todorov, I guess.
Comment 10 Alexander Todorov 2009-10-06 05:14:32 EDT
(In reply to comment #8)
> Any luck reproducing?  

No. I've tried with F12-Alpha-LiveCD on KVM host using:
1) start with clean disk image and select default partitioning
2) Edit lv_swap and make it encrypted
3) Click OK

The type doesn't change it stays "swap" and the encrypted icon is shown. 

Alexey,
can you give us more details about your steps to reproduce, package/distro versions, etc. If you can post a screen cast (using gtk-recordMyDesktop) that might be helpful.
Comment 11 Alexey Torkhov 2009-10-06 05:21:15 EDT
(In reply to comment #10)
> No. I've tried with F12-Alpha-LiveCD on KVM host using:

I was using latest nightly build from http://alt.fedoraproject.org/pub/alt/nightly-composes/desktop/

> Alexey,
> can you give us more details about your steps to reproduce, package/distro
> versions, etc. If you can post a screen cast (using gtk-recordMyDesktop) that
> might be helpful.

Will post screen cast if it won't work for you with nightly.
Comment 12 Alexander Todorov 2009-10-06 08:03:38 EDT
With the latest desktop ISO from the above link I can reproduce this bug:
1) start livecd as KVM guest
2) select default partitioning or use entire system
3) Modify the swap logical volume and enable the encrypted checkbox.
4) The type column goes from swap to Unknown and the install can't proceed in my case because I have only 512MB of memory for the virtual guest.
Comment 13 Alexey Torkhov 2009-10-06 08:25:21 EDT
(In reply to comment #12)
> install can't proceed in
> my case because I have only 512MB of memory for the virtual guest.  

With 512M of memory installation was successful with default partitioning.

As confirmed and pretty severe bug, adding this to F12Blocker tracker.
Comment 14 James Laska 2009-10-09 10:58:52 EDT
Adding for discussion in F-12 Beta blocker review meeting
Comment 15 James Laska 2009-10-09 11:57:37 EDT
I'm able to reproduce this consistently now live images built from rawhide as of 2009-10-09.  Available soon on http://alt.fedoraproject.org/pub/alt/nightly-composes/desktop/
Comment 16 David Lehman 2009-10-12 14:50:47 EDT
The new key escrow functionality, which is only usable via kickstart, had a dependency which was not present in the live images. This prevented loading of the module that handles LUKS formatting.

Will be fixed in anaconda-12.37-1 for F12 and anaconda-13.4-1 for rawhide.
Comment 17 James Laska 2009-10-13 10:56:25 EDT
Tested using a custom built live image of the desktop spin that contains anaconda-12.37-1.  No longer able to reproduce the reported failure.

Alexey, can you confirm as well?

NOTE: you will need anaconda-12.37 which isn't included in the live image as of this post.  You can either create or download a live image that includes anaconda-12.37, or install it on an existing live image.

http://alt.fedoraproject.org/pub/alt/nightly-composes/
Comment 18 James Laska 2009-10-14 14:34:38 EDT
Moving to CLOSED RAWHIDE.  I have tested this on nightly composes containing anaconda-12.38-1 and am not able to reproduce the failure.  Feel free to reopen this issue if the problem remains

Note You need to log in before you can comment on or make changes to this bug.