Bug 52694 - /dev/cdrom link not created automatically with NFS kickstart install
Summary: /dev/cdrom link not created automatically with NFS kickstart install
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kudzu   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-28 07:58 UTC by Need Real Name
Modified: 2014-03-17 02:23 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-20 08:19:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-08-28 07:58:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010808

Description of problem:
I'm using kickstart install over NFS. The /dev/cdrom link does not
get created automatically. Isn't it supposed to do that?


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Do kickstart install
2. Reboot



Actual Results:  The thing checking fstab complains about not finding
/dev/cdrom,
and it really isn't there.


Additional info:

Comment 1 Brent Fox 2001-08-28 18:11:35 UTC
Yes, it is supposed to make a /dev/cdrom link.  I don't know why it wouldn't. 
What kind if cdrom drive is in the machine?

Comment 2 Need Real Name 2001-08-29 05:58:21 UTC
from dmesg:
hdc: CD-ROM 50X, ATAPI CD/DVD-ROM drive

In other words plain old cd-rom drive. I have now installed RH 7.1 into about
15 computers, all with the same symptoms. With Red Hat 6.2, no problems.

And now that I think a bit more, I recall that there appears on one VC
messages like "cannot open cd-rom". I didn't pay much attention to them,
because I'm installing over NFS.


Comment 3 Brent Fox 2001-08-29 19:14:08 UTC
This is very strange because I have never seen this in any of my testing and I
do NFS installs every day...

Comment 4 Brent Fox 2001-08-29 19:26:30 UTC
Are these DVD drives?  I've seen one other report of a DVD drive having problems.

Comment 5 Need Real Name 2001-08-30 06:15:43 UTC
No, they are all common cd-rom drives. Is there any additional information I
could provide to you?



Comment 6 Jeremy Katz 2001-08-30 22:40:44 UTC
Are you not installing or not enabling the kudzu service?  The /dev/cdrom link
is created by kudzu during the boot process

Comment 7 Need Real Name 2001-08-31 05:28:28 UTC
I am installing kudzu and it is invoked normally when I boot up.
Next week I'm going to make a couple of new installs. I then check more
thoroughly if the link gets created at all, is kudzu removing it or
something like that.


Comment 8 Jeremy Katz 2001-08-31 05:31:10 UTC
Changing component to kudzu

Comment 9 Bill Nottingham 2001-08-31 13:51:08 UTC
What does 'kudzu -p -c cdrom' say?

Comment 10 Need Real Name 2001-08-31 15:19:35 UTC
-
class: CDROM
bus: IDE
detached: 0
device: hdc
driver: ignore
desc: "SAMSUNG CD-ROM SC-152C"-


Comment 11 Need Real Name 2001-09-20 08:19:45 UTC
Hi! I finally figured out what was the problem. Local install script added
/dev/cdrom /mnt/cdrw fstab entry and that somehow made kudzu fail.


Comment 12 Bill Nottingham 2002-01-04 03:23:20 UTC
Ah, updfstab won't make the link if an entry already exists in /etc/fstab that
it didn't write.


Note You need to log in before you can comment on or make changes to this bug.