Bug 526973 - kernel panics from the anaconda kernel when kvm guests have more than 3GB of RAM
kernel panics from the anaconda kernel when kvm guests have more than 3GB of RAM
Status: CLOSED INSUFFICIENT_DATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.4
All Linux
low Severity medium
: ---
: ---
Assigned To: Amit Shah
Lawrence Lim
:
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2009-10-02 15:46 EDT by Brenton Leanhardt
Modified: 2014-03-25 21:02 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-13 23:14:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Guest with 3GB + 1MB (failed to start) (1.42 KB, text/xml)
2009-10-02 15:46 EDT, Brenton Leanhardt
no flags Details
screendump when crash (25.06 KB, image/png)
2010-03-02 06:59 EST, jason wang
no flags Details

  None (edit)
Description Brenton Leanhardt 2009-10-02 15:46:13 EDT
Created attachment 363519 [details]
Guest with 3GB + 1MB (failed to start)

Description of problem:
The virt host is a Dell 7400 (2x4 Core Xeon E5410) with 32 GB of RAM and is running RHEL 5.4.  The guests are also running RHEL 5.4.  Whenever we set the RAM above 3072 MB the guests fail to boot into the anaconda kernel.  If we set the RAM to exactly 3072MB the guest will install successfully.  After installation we are able to boot the guest with 4GB of RAM by editing the xml config.

I have tried several different guest installations and received a few different types of errors.  Consistently on this hardware it will fail when the guest has more than 3GB of RAM.  Below you will find the various scenarios I tried.  The bulleted items represent what I considered interesting console messages.  The strangest one is related to the initramfs.  At install/boot time it will hang on that line for what seems like a few minutes before saying it is or is not initramfs.  When the guests have 3072 MB of RAM the bootup is so fast that line is not even noticeable.

3500,4096
* testing NMI watchdog ... <4>WARNING: CPU#0: NMI appears to be stuck (0->0)!
* checking is image is initramfs... it is
* kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(9,1)

3073
* testing NMI watchdog ... <4>WARNING: CPU#0: NMI appears to be stuck (0->0)!
* checking if image is initramfs...it isn't (invalid compressedc format (err=1)); looks like an initrd
* Freeing initrd memory: 7226k freed

3100
* checking is image is initramfs... it is
* a stack trace

3140
∘ same as 3073 except the vfb goes black after apparently hanging



Version-Release number of selected component (if applicable):
Host:
2.6.18-164.el5 #1 SMP Tue Aug 18 15:51:48 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux
kernel-2.6.18-164.el5
kmod-kvm-83-80.el5
kvm-83-80.el5
libvirt-0.6.3-11.el5

Guest:
Same OS



Additional info:
I will attach the qemu xml files for the attempted kickstarts so you can see the exact configuration of the guests.  I'm sure there is better information I could provide.  Just tell me what you need.
Comment 1 Brenton Leanhardt 2009-10-02 15:47:55 EDT
All the other guest xml files were essentially identical.  If there's any value in attaching them, just let me know.
Comment 3 Dor Laor 2010-01-04 07:36:00 EST
Can you please retest on newer kvm-83-142 ?
Comment 5 jason wang 2010-03-02 06:58:28 EST
I also met maybe the same problem during the unattended installation test of RHEL-5.4 installation.

The qemu-kvm cmdline is: qemu -name 'vm1' -monitor tcp:0:6001,server,nowait -drive file=/usr/local/staf/test/RHEV/kvm-new/kvm-test/tests/kvm/images/RHEL-Server-5.4-32.raw,if=ide,cache=writethrough,boot=on -net nic,vlan=0,model=e1000,macaddr=00:19:30:09:8A:00 -net user,vlan=0 -m 4096 -smp 2 -drive file=/usr/local/staf/test/RHEV/kvm-new/kvm-test/tests/kvm/isos/linux/rhel-server-5.4-i386-dvd.iso,index=2,media=cdrom -soundhw ac97 -fda /usr/local/staf/test/RHEV/kvm-new/kvm-test/tests/kvm/images/floppy.img -tftp /usr/local/staf/test/RHEV/kvm-new/kvm-test/tests/kvm/images/tftpboot -usbdevice tablet -rtc-td-hack -no-hpet -cpu qemu64,+sse2 -no-kvm-pit-reinjection -bootp /pxelinux.0 -boot n -vnc :0

The kvm version is: kvm-83-105.el5_4.28  host kernel is kernel-2.6.18-164.14.1.el5
Comment 6 jason wang 2010-03-02 06:59:33 EST
Created attachment 397299 [details]
screendump when crash
Comment 7 Amit Shah 2010-04-13 03:08:53 EDT
Are you using a 32-bit guest? Can you try a 64-bit guest?

Also, Can you check with the latest packages for kvm on 5.4?
Comment 8 Amit Shah 2010-05-03 06:23:06 EDT
Please also test on 5.5 and 6.0 nightly snapshots.
Comment 9 Amit Shah 2010-08-31 00:58:09 EDT
Any new information from further tests? I faintly remember there being an issue in the guest kernel but can't really point a finger to it right now.
Comment 12 RHEL Product and Program Management 2011-01-11 15:53:00 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 13 RHEL Product and Program Management 2011-01-11 17:47:17 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 14 Amit Shah 2011-01-13 23:14:17 EST
Stuck in needinfo for long; closing.  Please open another bug report if you face the problem again.

Note You need to log in before you can comment on or make changes to this bug.