Bug 527020 - [anaconda] changes boot partition without notification/confirmation
[anaconda] changes boot partition without notification/confirmation
Status: CLOSED DUPLICATE of bug 533658
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-03 05:53 EDT by Joachim Frieben
Modified: 2009-11-30 05:58 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-30 05:58:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Output of fdisk -l /dev/sda after "rawhide" install (445 bytes, text/plain)
2009-10-03 05:53 EDT, Joachim Frieben
no flags Details
Install log file anaconda.log (85.16 KB, text/plain)
2009-10-03 05:54 EDT, Joachim Frieben
no flags Details
Install log file storage.log (70.72 KB, text/plain)
2009-10-03 05:56 EDT, Joachim Frieben
no flags Details
Install log file syslog (56.75 KB, text/plain)
2009-10-03 05:56 EDT, Joachim Frieben
no flags Details

  None (edit)
Description Joachim Frieben 2009-10-03 05:53:04 EDT
Created attachment 363546 [details]
Output of fdisk -l /dev/sda after "rawhide" install

Description of problem:
After a fresh install from the current "rawhide" tree, the system boots directly from /dev/sda2 which had been set up to be mounted as /boot during install, and which had also been chosen as target of the boot loader.
However, I am used to booting into Fedora via NTLDLR, and until recently, the boot flag of the Windows XP partition /dev/sda1 which was the boot partition before the "rawhide" install had never been touched by anaconda.
Given that this modification is performed without notification nor confirmation requested from the user, I do consider this change a bug.

Version-Release number of selected component (if applicable):
anaconda-12.30-1.fc12.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Perform fresh install from the "rawhide" tree and choose /dev/sda2 as destination of the boot loader.
  
Actual results:
New system boots from /dev/sda2 even though it used to boot from /dev/sda1.

Expected results:
New system boots from /dev/sda1 as before.

Additional info:
FDISK allows to toogle the boot flag of /dev/sda1 and /dev/sda2 in order to revert the change of the boot partition. The system then allows again to boot into Fedora via NTLDR flawlessly after updating the boot sector image C:\GRUB.INI.
Comment 1 Joachim Frieben 2009-10-03 05:54:53 EDT
Created attachment 363548 [details]
Install log file anaconda.log
Comment 2 Joachim Frieben 2009-10-03 05:56:16 EDT
Created attachment 363549 [details]
Install log file storage.log
Comment 3 Joachim Frieben 2009-10-03 05:56:44 EDT
Created attachment 363550 [details]
Install log file syslog
Comment 4 Bug Zapper 2009-11-16 08:13:22 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Hans de Goede 2009-11-30 05:58:10 EST
Further evaluation of our new boot flag setting behavior has lead to the conclusion that the removal of the active flag from an existing partition indeed is unwanted behavior.

So I've just changed this, and for F-13 we will no longer do that, see:
http://git.fedorahosted.org/git/?p=anaconda.git;a=commitdiff;h=0c0559f6f187815521364cb6d5118ad9faf24cc9

*** This bug has been marked as a duplicate of bug 533658 ***

Note You need to log in before you can comment on or make changes to this bug.