Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 527031 - Permission problems with Epson Stylus SX405 AiO
Summary: Permission problems with Epson Stylus SX405 AiO
Keywords:
Status: CLOSED DUPLICATE of bug 512516
Alias: None
Product: Fedora
Classification: Fedora
Component: sane-backends
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-03 14:13 UTC by Felix Kaechele
Modified: 2009-10-22 10:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-22 10:10:50 UTC
Type: ---


Attachments (Terms of Use)

Description Felix Kaechele 2009-10-03 14:13:18 UTC
Description of problem:
First of all:
The epson2 backend is lacking the USB ID for this model:
Bus 001 Device 011: ID 04b8:084a Seiko Epson Corp.
The 19-libsane.fdi HAL info file however has it.

Furthermore:
When trying to scan as user xsane complains that it cannot find any devices. Running xsane as root works; the scanner is found and scanning works great with the epson2 backend.
Running xsane with strace reveals that the there are permission problems with the usb devices:
getdents(6, /* 11 entries */, 32768)    = 264
open("/dev/bus/usb/001/011", O_RDWR)    = -1 EACCES (Permission denied)
open("/dev/bus/usb/001/011", O_RDONLY)  = 7
ioctl(7, USBDEVFS_CONNECTINFO, 0x7fffa478ee70) = -1 EPERM (Operation not permitted)
read(7, "\22\1\0\2\0\0\0@\270\4J\10\0\1\1\2\3\1"..., 18) = 18
read(7, "\t\2N\0\3\1\4\300"..., 8)      = 8
read(7, "\1\t\4\0\0\2\377\377\377\5\7\5\1\2\0\2\0\7\5\202\2\0\2\0\t\4\1\0\2\7\1\2\6"..., 70) = 70
close(7)                                = 0

My Canon LIDE 25 scanner works without permission problems.

Version-Release number of selected component (if applicable):
hal-0.5.13-7.fc12.x86_64
hal-info-20090716-3.fc12.noarch
sane-backends-1.0.20-7.fc12.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. plug in scanner
2. start xsane
3. watch it fail
  
Actual results:
xsane fails to identify and use the scanner

Expected results:
xsane identifies the scanner and scans an image correctly

Comment 1 Alesh Slovak 2009-10-22 07:26:35 UTC
I am a developer on the iscan/epkowa package. When testing iscan compatibility with the Fedora 12 Beta I came upon this problem.

Using an Epson PX-A620 (product/vendor id: 04b8/082f) I can scan with scanimage via the provided epson2 backend only as root. As a regular user I get permissions errors. I've seen problems with SELinux in the past, so tried disabling it, but that didn't change the situation.

The PX-A620 is listed in /usr/share/hal/fdi/information/20thirdparty/19-libsane.fdi. What happened to scanner permissions in Fedora 12?

iscan uses the distribution's libsane fdi and udev rules (if available) files to create its own, so if permissions don't work for the scanners supported by the distribution itself, they won't work for iscan either.

How could it be that Felix had no permissions problems with his Canon scanner? 
Felix, did you install any software in addition to sane-backends?

It would be a real shame to release Fedora 12 with broken scanner permissions.

Comment 2 Felix Kaechele 2009-10-22 10:01:21 UTC
No, I did not install any additional packages to use my scanners. The Canon LIDE 20 worked out of the box, my Epson Stylus SX405 only worked after adding "usb 0x4b8 0x84a" to /etc/sane.d/epson2.conf and then again only when xsane is running as root.

Comment 3 Nils Philippsen 2009-10-22 10:10:50 UTC

*** This bug has been marked as a duplicate of bug 512516 ***


Note You need to log in before you can comment on or make changes to this bug.