Bug 527056 - device-mapper: ioctl: unable to remove open device temporary-cryptsetup-930
device-mapper: ioctl: unable to remove open device temporary-cryptsetup-930
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-03 15:17 EDT by Bruno Wolff III
Modified: 2010-01-27 19:52 EST (History)
5 users (show)

See Also:
Fixed In Version: 004-4.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-27 19:52:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
do not run blkid on dm internal devices (1.05 KB, patch)
2009-11-03 10:43 EST, Michal Schmidt
no flags Details | Diff

  None (edit)
Description Bruno Wolff III 2009-10-03 15:17:02 EDT
Description of problem:
When booting using am initramfs image made with dracut (but not initrd images made with mkinitrd) I get some warnings on boot. I haven't notice any lasting consequences from them, but I suspect that something is amiss.


Version-Release number of selected component (if applicable):
dracut-002-11.gita8a3ca51.fc12.noarch (But the problem goes back a ways, I had originally thought this was part of bug 523862, but it wasn't)

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Buffer I/O error on device dm-0, logical block 64
Buffer I/O error on device dm-0, logical block 65
Buffer I/O error on device dm-0, logical block 66
Buffer I/O error on device dm-0, logical block 67
Buffer I/O error on device dm-0, logical block 68
Buffer I/O error on device dm-0, logical block 69
Buffer I/O error on device dm-0, logical block 70
Buffer I/O error on device dm-0, logical block 71
device-mapper: ioctl: unable to remove open device temporary-cryptsetup-930
Buffer I/O error on device dm-0, logical block 72
Buffer I/O error on device dm-0, logical block 73  

Expected results:
No warning messages.

Additional info:
http://smolt.fedoraproject.org/client/show_all/pub_9915137d-5ecc-4aae-bda9-17366f207a68
Non comments from fstab
/dev/md0                /boot                   ext4    defaults        1 2
/dev/mapper/luks-f92cb175-069f-46a4-98ca-a6beb32719bb /                       ex
t4    defaults        1 1
/dev/mapper/luks-b80e010b-375c-4567-9e8e-d92dc7effc17 /spare                  ex
t4    defaults        1 2
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
Comment 1 Bruno Wolff III 2009-10-04 12:47:25 EDT
It was requested to note https://bugzilla.redhat.com/show_bug.cgi?id=526699#c5 in this bug as being relevant.
Comment 2 Michal Schmidt 2009-11-03 10:06:19 EST
[CC Peter]

Peter,
could you take a look at the udev rules in /usr/share/dracut/modules.d/* ? One of them may be causing this bug. For instance /usr/share/dracut/modules.d/95udev-rules/59-persistent-storage.rules seems to run blkid on dm-* devices without filtering the internal devices...
Comment 3 Michal Schmidt 2009-11-03 10:43:23 EST
Created attachment 367315 [details]
do not run blkid on dm internal devices

This patch solves the bug on my system. What do you think?
Comment 4 Harald Hoyer 2009-11-03 10:48:44 EST
do we need the ENV import with the new dm rules, which are also installed?
Comment 5 Peter Rajnoha 2009-11-03 10:56:53 EST
(In reply to comment #3)
> Created an attachment (id=367315) [details]
> do not run blkid on dm internal devices
> 
> This patch solves the bug on my system. What do you think?  

Looks good.

(In reply to comment #4)
Well, we don't have DM/LVM rules in F12, only in F13 and up...

Anyway, if there are more blkid calls, I'd suggest adding this filter into 01-ignore.rules, if possible, so we don't have to repeat it over and over again in all the other rules (temporariliy for F12 versions of dracut). But I haven't tested this option...
Comment 6 Michal Schmidt 2009-11-03 11:17:44 EST
Bug 528909, which has very similar effects, was classified as F12Blocker. Should this one be a blocker too?
Comment 7 Adam Williamson 2009-11-03 11:29:07 EST
frankly 528909 stayed on the blocker list because no-one in the review meeting (including me) was entirely sure what the effects _were_, so we erred on the side of caution. as long as the effects are nothing but printing error messages, then no, it's not a blocker. if the effects are potentially more serious, it could be. we need a For-Dummies account of the possible effects of the bug to be sure.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Bug Zapper 2009-11-16 08:14:23 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Fedora Update System 2009-11-27 10:12:09 EST
dracut-003-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/dracut-003-1.fc12
Comment 10 Fedora Update System 2009-11-30 23:39:33 EST
dracut-003-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dracut'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12432
Comment 11 Bruno Wolff III 2009-12-01 10:43:02 EST
I am no longer seeing this on F12 or F13. (On F13 2.6.32 isn't working for me, so I am using an F12 kernel.) So everything looks good from here.
Comment 12 Tom London 2009-12-03 10:37:47 EST
I am seeing this message with fc13 (kernel-2.6.32-0.63.rc8.git2.fc13.x86_64, dracut-003-1.fc13.noarch) when I connect a LUKS-encrypted USB hard drive after the system has booted and I've been logged in for a while:

Dec  3 07:19:45 tlondon kernel: sdc: sdc1
Dec  3 07:19:45 tlondon kernel: sd 5:0:0:0: [sdc] Assuming drive cache: write through
Dec  3 07:19:45 tlondon kernel: sd 5:0:0:0: [sdc] Attached SCSI disk
Dec  3 07:19:53 tlondon kernel: usb 1-5.3: reset high speed USB device using ehci_hcd and address 7
Dec  3 07:20:30 tlondon kernel: padlock: VIA PadLock Hash Engine not detected.
Dec  3 07:20:30 tlondon modprobe: FATAL: Error inserting padlock_sha (/lib/modules/2.6.32-0.63.rc8.git2.fc13.x86_64/kernel/drivers/crypto/padlock-sha.ko): No such device
Dec  3 07:22:07 tlondon kernel: device-mapper: ioctl: unable to remove open device temporary-cryptsetup-14952
Dec  3 07:24:49 tlondon kernel: device-mapper: ioctl: unable to remove open device temporary-cryptsetup-15092

The drive is recognized, and I get a window requesting the LUKS password.  However, the password is rejected.

I then use /usr/bin/palimpsest an try to unlock the drive.  I enter the proper passphrase 10 times before the device is successfully unlocked.  I see no graphical messages, nor anything in /var/log/messages except the above message.  And I only get that message occasionally. 

Once palimpsest unlocks the drive, I can mount it and use it as normal.

Is this the same problem?  Not sure where dracut enters in....
Comment 13 Bruno Wolff III 2009-12-03 12:19:15 EST
That's a different problem. It is covered by bug 539282. But your case seems to be a different twist on the issue. So you may want to add the above information there.
Comment 14 Fedora Update System 2010-01-26 05:47:23 EST
dracut-004-4.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/dracut-004-4.fc12
Comment 15 Fedora Update System 2010-01-26 20:05:04 EST
dracut-004-4.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dracut'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-1088
Comment 16 Fedora Update System 2010-01-27 19:50:19 EST
dracut-004-4.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.