Bug 527087 - qemu-common postinstall scriptlet uses getent before it's installed
qemu-common postinstall scriptlet uses getent before it's installed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
rawhide
All Linux
high Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12VirtBlocker
  Show dependency treegraph
 
Reported: 2009-10-04 05:48 EDT by Bruce Jerrick
Modified: 2009-10-12 03:16 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 537044 (view as bug list)
Environment:
Last Closed: 2009-10-12 03:16:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bruce Jerrick 2009-10-04 05:48:52 EDT
Description of problem:
The qemu-common postinstall scriptlet tries to execute 'getent', but that
may not exist yet, due to a missing Requires(post).

Version-Release number of selected component (if applicable):
qemu-common-0.11.0-2.fc12.i686.rpm

How reproducible:
Depends on package set (installation order).

Steps to Reproduce:
1. Install F12, including qemu-common.
2. grep -A3 "^Installing qemu-common" /root/install.log
  
Actual results:
Installing qemu-common-0.11.0-2.fc12.i686
/var/tmp/rpm-tmp.f9IFe3: line 1: getent: command not found
/var/tmp/rpm-tmp.f9IFe3: line 2: getent: command not found
/var/tmp/rpm-tmp.f9IFe3: line 3: getent: command not found

Expected results:
No "command not found" messages.

Additional info:
FIX: Add this to the qemu-common spec file:
    Requires(post): /usr/bin/getent

These should also be added (they're also used by postinstall):
    Requires(post): /usr/sbin/groupadd
    Requires(post): /usr/sbin/useradd
Comment 1 Mark McLoughlin 2009-10-09 06:33:30 EDT
Thanks Bruce, will fix for F-12

Note, https://fedoraproject.org/wiki/Packaging:UsersAndGroups suggests requiring shadow-utils and doing it in %pre

I don't think we need to do it in %pre, since we don't install any files owned by this user/group - the first time one of them should be used is when we load the kvm modules in qemu-system-x86 %post and udev creates the /dev/kvm node
Comment 2 Mark McLoughlin 2009-10-09 10:36:22 EDT
* Fri Oct  9 2009 Mark McLoughlin <markmc@redhat.com> - 2:0.11.0-6
- Fix fs errors with virtio and qcow2 backing file (#524734)
- Fix ksm initscript errors on kernel missing ksm (#527653)
- Add missing Requires(post): getent, useradd, groupadd (#527087)
Comment 3 Mark McLoughlin 2009-10-09 12:01:46 EDT
tag request: https://fedorahosted.org/rel-eng/ticket/2429
Comment 4 Mark McLoughlin 2009-10-12 03:16:54 EDT
tagged now for F12 GA

Note You need to log in before you can comment on or make changes to this bug.