Bug 527103 - squeak-vm does`nt start
Summary: squeak-vm does`nt start
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: squeak-vm
Version: 11
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Gavin Romig-Koch
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-04 14:32 UTC by Michael
Modified: 2009-10-07 14:42 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2009-10-07 14:42:06 UTC


Attachments (Terms of Use)

Description Michael 2009-10-04 14:32:14 UTC
Description of problem: 
I have only Smalltalk environment in application. Click on this item does`nt run squeak-vm. No default image in ~/MySqueak/default

Version-Release number of selected component (if applicable):

squeak-vm 3.10.5-1

How reproducible:

always

Steps to Reproduce:
1. run mysqueak in application menu
2.
3.
  
Actual results:

nothing happen

Expected results:

start squeak with some default image

Additional info:

Comment 1 Steven M. Parrish 2009-10-04 15:07:28 UTC
Squeak-vm is just the virtual machine for and is itself not an application.  You need the etoys package to actually use the vm.    Also these packages are meant to be used in the Sugar learning environment.  Do you have Sugar installed?

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 2 Michael 2009-10-04 16:13:12 UTC
No, I have not Sugar installed.
I have the etoys package installed.

[midnighter@localhost ~]$ rpm -qa | grep etoys
etoys-4.0.2212-1.fc11.noarch

Comment 3 Gavin Romig-Koch 2009-10-05 19:32:14 UTC
You don't need Sugar installed to run Squeak or EToys, both run just fine under Gnome or KDE.  EToys also runs under Sugar.

Squeak and EToys are different things (at least on Fedora for the time being), although they both rely on and run on the Squeak VM.

As you are aware, to run Squeak you need both an image and a vm.  The vm is provided by the squeak-vm package, a default image, the basic Squeak image from squeak.org, is provided by the squeak-image package.  Michael, I'm guessing that you don't have squeak-image installed on your system.

The etoys package is a squeak image, and some wrapper files to make it work well with Sugar and Gnome (and other desktops), distributed by squeakland.org.  Like the squeak-image package, the etoys package relies on and requires the squeak-vm package.

Although you do need a squeak image to run squeak, you are not required to use either the images provided by squeak-image or etoys packages.  You can use whatever image you want with the provided squeak-vm in exactly the same way you would on any Unix/Unix like system.  For example, create a new directory, put your favorite squeak.image, squeak.changes, and SqueakV3.sources in it, and run squeak.

If you want to use your own image with the MySqueak menu item (and mysqueak command), create a directory ~/MySqueak/default/, and put your favorite squeak.image, squeak.changes, and SqueakV3.sources in it.

I apologize that this is not simpler.  I have plans to make it simpler, but I haven't had time to implement them yet.

Michael, if after ensuring that you have installed squeak-image in addition to squeak-vm, the MySqueak menu item still does not work, please bring up a command line terminal, and run the command "mysqueak" (all lower case, one word, no arguments), and paste the output into this bz.

Comment 4 Michael 2009-10-06 18:18:55 UTC
Thanks, I use my favorite image in directory ~/MySqueak/default/ with image has taken from http://squeakvm.org/unix/release/.

I run squeak

[midnighter@localhost default]$ pwd
/home/midnighter/MySqueak/default
[midnighter@localhost default]$ ls
squeak.changes  squeak.image  SqueakScreen.ps
[midnighter@localhost default]$ squeak squeak.image

I can`t install squeak-image because have not squeak-image in repositories

[midnighter@localhost ~]$ yum search squeak
etoys.noarch : A media-rich model, game, and simulation construction kit and authoring tool
squeak-vm.x86_64 : The Squeak virtual machine
squeak-vm-nonXOplugins.x86_64 : Non-XO Plugins for the Squeak virtual machine
[midnighter@localhost ~]$

Comment 5 Gavin Romig-Koch 2009-10-06 20:20:14 UTC
(In reply to comment #4)
>
> I can`t install squeak-image because have not squeak-image in repositories
> 
> [midnighter@localhost ~]$ yum search squeak
> etoys.noarch : A media-rich model, game, and simulation construction kit and
> authoring tool
> squeak-vm.x86_64 : The Squeak virtual machine
> squeak-vm-nonXOplugins.x86_64 : Non-XO Plugins for the Squeak virtual machine
> [midnighter@localhost ~]$  

bizzare!  What do you get for:

   yum list 'squeak-*'

and

   yum repolist


[gavin@dhcp243-41 ~]$ yum search squeak
Loaded plugins: dellsysidplugin2, priorities, refresh-packagekit
=============================== Matched: squeak ================================
etoys.noarch : A media-rich model, game, and simulation construction kit and
             : authoring tool
squeak-image.noarch : The image files for Squeak
squeak-vm.x86_64 : The Squeak virtual machine
squeak-vm-nonXOplugins.x86_64 : Non-XO Plugins for the Squeak virtual machine

[gavin@dhcp243-41 ~]$ yum list 'squeak-*'
Loaded plugins: dellsysidplugin2, priorities, refresh-packagekit
Available Packages
squeak-image.noarch                       3.10.2.7179-2.fc11             fedora 
squeak-vm.x86_64                          3.10.5-1.fc11                  updates
squeak-vm-nonXOplugins.x86_64             3.10.5-1.fc11                  updates

[gavin@dhcp243-41 ~]$ yum repolist
Loaded plugins: dellsysidplugin2, priorities, refresh-packagekit
repo id              repo name                                   status
adobe-linux-i386     Adobe Systems Incorporated                  enabled:     17
fedora               Fedora 11 - x86_64                          enabled: 16,577
updates              Fedora 11 - x86_64 - Updates                enabled:  7,074

Comment 6 Michael 2009-10-06 20:58:55 UTC
[midnighter@localhost ~]$ yum list 'squeak-*'
Loaded plugins: changelog, dellsysidplugin2, downloadonly, fastestmirror, presto, refresh-packagekit
Installed Packages
squeak-vm.x86_64                                                                3.10.5-1.fc11                                                        @updates
Available Packages
squeak-image.noarch                                                             3.10.2.7179-2.fc11                                                   fedora
squeak-vm-nonXOplugins.x86_64                                                   3.10.5-1.fc11             

[midnighter@localhost ~]$ yum repolist
Loaded plugins: changelog, dellsysidplugin2, downloadonly, fastestmirror, presto, refresh-packagekit
repo id                                                      repo name                                                                        status
fedora                                                       Fedora 11 - x86_64                                                               enabled: 16 577
rpmfusion-free                                               RPM Fusion for Fedora 11 - Free                                                  enabled:    423
rpmfusion-free-updates                                       RPM Fusion for Fedora 11 - Free - Updates                                        enabled:    409
rpmfusion-nonfree                                            RPM Fusion for Fedora 11 - Nonfree                                               enabled:    121
rpmfusion-nonfree-updates                                    RPM Fusion for Fedora 11 - Nonfree - Updates                                     enabled:    214
updates                                                      Fedora 11 - x86_64 - Updates                                                     enabled:  7 074
repolist: 24 818

[midnighter@localhost ~]$ yum search squeak
Loaded plugins: changelog, dellsysidplugin2, downloadonly, fastestmirror, presto, refresh-packagekit
====================================================================== Matched: squeak ======================================================================
etoys.noarch : A media-rich model, game, and simulation construction kit and authoring tool
squeak-image.noarch : The image files for Squeak
squeak-vm.x86_64 : The Squeak virtual machine
squeak-vm-nonXOplugins.x86_64 : Non-XO Plugins for the Squeak virtual machine

Yeah! Now I have squeak-image! I don`t knows why I have not it not before.

Now I have default image in ~/MySqueak/default, and click on MySqueak item into the application run squeak-vm. Thanks! Solved.


Note You need to log in before you can comment on or make changes to this bug.