Bug 52711 - vnc-server should not default to twm window manager
Summary: vnc-server should not default to twm window manager
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: vnc (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-28 12:05 UTC by Johan Walles
Modified: 2007-04-18 16:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-28 18:02:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Johan Walles 2001-08-28 12:05:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.3) Gecko/20010801

Description of problem:
The vnc-server package should not default to the TWM window manager. 
Instead, it should use the user's default session, just like
/etc/X11/xinit/Xclients does.

Version-Release number of selected component (if applicable):
3.3.3r2

How reproducible:
Always

Steps to Reproduce:
1. Install the vnc-server RPM.
2. Connect to it from an external machine.



Actual Results:  I get a TWM-based desktop.



Expected Results:  I wanted a GNOME desktop.

Additional info:

Possibly the default ~/.vnc/xstartup script created by the vncserver script
should call the /etc/X11/xinit/Xclients script instead of the current
let's-start-twm-because-it's-available-on-most-unices mess.

Or to put it another way, at the top of the vncserver script, the
$defaultXStartup variable should be set to:
("#!/bin/sh\n" . "/etc/X11/xinit/Xclients\n")
and nothing else.

Comment 1 Tim Waugh 2001-08-28 12:08:27 UTC
Seems like a good idea.


Comment 2 Tim Waugh 2001-09-18 15:10:47 UTC
Implemented in 3.3.3r2-19.


Comment 3 Tim Waugh 2001-10-18 15:35:41 UTC
Hmm, actually, Xclients uses the _system_'s default desktop.  It should use 
/etc/X11/xinit/xinitrc to pick up the user's default desktop.


Comment 4 Tim Waugh 2001-11-04 10:22:04 UTC
Fixed in 3.3.3r2-21.



Note You need to log in before you can comment on or make changes to this bug.