Bug 527123 - Changing DVD Drives Results in No /dev cdrom nor dvd Link
Changing DVD Drives Results in No /dev cdrom nor dvd Link
Status: CLOSED DUPLICATE of bug 570561
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
11
All Linux
low Severity low
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-04 14:05 EDT by Bill Adams
Modified: 2010-03-17 13:21 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-17 08:01:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bill Adams 2009-10-04 14:05:18 EDT
In my original install of Fedora 11, I had one IDE connected DVD RW drive. The drive went bad so I replaced it with a SATA DVD RW drive. The /dev/cdrom, etc. links did not update to point to the new device -- breaking many applications that expect those links to be there.

Searching for a solution online is difficult because any search with "fedora" and "dvd" in it generally returns results on how to install fedora.


I eventually figured out to "ls -l /dev/disk/by-path/" to get the replacement ID_PATH to put into /etc/udev/rules.d/70-persistent-cd.rules and to "echo add > /sys/class/block/sr0/uevent" to get the devices to be created, but I doubt that normal users would get to that point.

I had been manually creating symlinks but of course those would get deleted on each reboot.

One could argue this is a corner case: Normal users probably would not be replacing hardware themselves, and replacing a DVD drive is not a common occurrence into its self.

To me a perfectly fine solution would be if 70-persistent-cd.rules had in the comments how to fix the file when new hardware was added or changed. I tried to figure out the "write_cd_rules" program mentioned in said file...but could never figure out how to get that program to work.

Thanks for your time and help.
Comment 1 Harald Hoyer 2010-03-17 08:01:19 EDT

*** This bug has been marked as a duplicate of bug 570561 ***
Comment 2 Steve Tyler 2010-03-17 08:25:14 EDT
A simple work-around is to remove /etc/udev/rules.d/70-persistent-cd.rules and restart.  (Bug 570490, Comment 13)

"... breaking many applications that expect those links to be there."

Bill: Could you list some of those applications?

See also:
Bug 570490 - /dev/cdrom not created after optical drive replaced
Comment 3 Bill Adams 2010-03-17 12:31:34 EDT
Boy it has been a while. I should have named the program. I usually use abcde and tscat...and obviously I can change the path to the device on those easily. Whatever program I was using did not have an intuitive/easy way to change the device path. I'll dig in my brain to see if I can remember. I think it was VirtualBox OSE because there is no GUI way to change the DVD/CDROM device that I have found.
Comment 4 Steve Tyler 2010-03-17 13:21:24 EDT
(In reply to comment #3)
> Boy it has been a while. I should have named the program. I usually use abcde
> and tscat...and obviously I can change the path to the device on those easily.
> Whatever program I was using did not have an intuitive/easy way to change the
> device path. I'll dig in my brain to see if I can remember. I think it was
> VirtualBox OSE because there is no GUI way to change the DVD/CDROM device that
> I have found.    

Thanks, Bill. I found abcde. tscat doesn't seem to be available in the F12 or rpmfusion repos. Still looking at VirtualBox OSE.
(Bug 570490, Comment 25)

Note You need to log in before you can comment on or make changes to this bug.