Bug 52713 - Need sanity checking on location user selects for boot loader to be written
Need sanity checking on location user selects for boot loader to be written
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-28 08:24 EDT by Chris Rouch
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Rouch 2001-08-28 08:24:51 EDT
Description of Problem:

I did a fresh install on /dev/sda1 (first scsi disk), leaving my ide disks alone. I 
selected grub as the boot loader. I forget whether i selected /dev/sda or 
/dev/sda1 for the MBR. After installation, on reboot, the machine hung at 'LI'

Version-Release number of selected component (if applicable):


How Reproducible:
yes

Steps to Reproduce:
1.  unplug ide disks
2.  install seawolf on scsi disks (/dev/sda1 = /)
3. plug in ide disks
4. install roswell, selecting grub as boot loader

Actual Results:

system hangs at 'LI'

Expected Results:

Grub splash screen followed by boot

Additional Information:
	I saw this before on seawolf, and fixed it the same way - I unplugged 
my ide disks and re-installed as before. After installlation and first boot, plug in ide disks, and everything works as it should.

	I'm sure this was user error, but it would have been nice for the 
installation to have removed (or offered to remove) any LILO intsallation.
Comment 1 Jeremy Katz 2001-08-28 16:03:14 EDT
Yes, you MUST continue to install your boot loader to the same place on a new
install or upgrade (well, you can move to the MBR from the partition, but not
vice versa). 

I'm going to look into adding some more sniffing for the boot loader in the
future to try to keep people from having this problem, but it's too late for
this release due to screen freezes.
Comment 2 Michael Fulbright 2002-03-26 12:46:02 EST
Deferring to future release.
Comment 3 Red Hat Bugzilla 2006-02-21 13:48:07 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.