Bug 527232 - RFE: add a --replace flag to virt-clone
RFE: add a --replace flag to virt-clone
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: virtinst (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Cole Robinson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-05 09:45 EDT by Dodji Seketeli
Modified: 2011-07-13 12:58 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-13 12:58:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dodji Seketeli 2009-10-05 09:45:38 EDT
Once we have virt-clone'd a running VM instance to an instance named e.g. "vm-backup" there is no easy way to virt-clone the same VM instance to the same "vm-backup" instance because virt-clone complains that "vm-backup" already exists.

Such a feature would be very useful though, to regularly backup a running VM instance.

Right now, the workaround method is to virsh undefine the "vm-backup" instance before virt-clone-ing to to it again.

So a virt-clone --replace flag would be very handy.
Comment 1 Mark McLoughlin 2009-10-09 09:04:16 EDT
I imagine we'd actually implement this by explicit storage snapshot capabilities - e.g. if you could create a snapshot of the VM (rather than cloning it) and later revert the VM to the snapshot

Anyway, this is an RFE - moving to upstream bug tracker for now

Note You need to log in before you can comment on or make changes to this bug.