Bug 52729 - '--justdb' operations ignore %_netsharedpath
'--justdb' operations ignore %_netsharedpath
Status: CLOSED DUPLICATE of bug 52725
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-28 10:39 EDT by Enrico Scholz
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-28 10:39:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2001-08-28 10:39:39 EDT
Description of Problem:

When upgrading with the '--justdb' flag the %_netsharedpath is ignored.

BTW: does there exists a reason why the example works as root only? When
executing as normal user, no error-messages appear but 'RPM -qa' gives no
output.


Version-Release number of selected component (if applicable):

rpm-4.0.3-0.96


Steps to Reproduce:
1. p=/var/tmp/rpm-netshared-test
2. alias RPM="rpm --root $p --eval %define\ _netsharedpath\ /usr/share/man"
3. mkdir -p $p/var/lib/rpm
4. RPM --initdb
5. RPM -U setup-2.5.4-1.noarch.rpm filesystem-2.1.5-2.noarch.rpm --justdb
6. RPM -qas | grep 'net shared'


Actual Results:

no output at (6)


Expected Results:

(6) gives out some directories


Additional Information:

setup and filesystem are from roswell2
Comment 1 Jeff Johnson 2001-08-28 10:51:12 EDT
With --root option, root is required because chroot(2) is root only (#49899).

With --justdb option, certain pathways involved in calculating file
disposition and state are skipped. Otherwise this is just a variant
duplicate of #52725.

*** This bug has been marked as a duplicate of 52725 ***

Note You need to log in before you can comment on or make changes to this bug.