Bug 527370 - Needs a rebuild with fixed gcc.
Needs a rebuild with fixed gcc.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: erlang (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
: EasyFix, Triaged
: 528261 530904 (view as bug list)
Depends On:
Blocks: F12Target
  Show dependency treegraph
 
Reported: 2009-10-06 02:49 EDT by Yanko Kaneti
Modified: 2009-12-09 23:05 EST (History)
7 users (show)

See Also:
Fixed In Version: R13B-01.3.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-09 23:05:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Yanko Kaneti 2009-10-06 02:49:54 EDT
Description of problem:
See gcc bug 527121 : fortify_fail in erlang code
Comment 1 Yanko Kaneti 2009-10-10 07:41:51 EDT
*** Bug 528261 has been marked as a duplicate of this bug. ***
Comment 2 Yanko Kaneti 2009-10-12 13:05:24 EDT
The fixed gcc is already tagged for f12. gcc-4.4.1-20
Comment 3 Yanko Kaneti 2009-10-26 03:31:25 EDT
*** Bug 530904 has been marked as a duplicate of this bug. ***
Comment 4 Kefah T. Issa 2009-11-03 02:56:01 EST
Hello,

Just confirm that I still encounter this problem. ... and on all apps that depend on erlang. in my case couchdb.

I am on the latest rawhide/fedora12 beta : 
gcc-4.4.2-7.fc12.x86_64

Regards,
- Kefah.
Comment 5 Lorenzo Villani 2009-12-05 20:18:40 EST
Rebuilding erlang against latest gcc fixes the issue. Please submit a rebuild of erlang in koji.
Comment 6 Kevin Kofler 2009-12-09 01:19:20 EST
Given that the fix is trivial, I'm just going to rebuild this on Lorenzo's request. I have confirmed that only F12 is affected: F13 already got a new build against a fixed GCC, the F11 version was built with an older GCC and does not exhibit this problem.
Comment 7 Fedora Update System 2009-12-09 02:18:35 EST
erlang-R13B-01.3.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/erlang-R13B-01.3.fc12
Comment 8 Fedora Update System 2009-12-09 23:05:46 EST
erlang-R13B-01.3.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.