This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 527514 - No root device found, boot has failed using lxde liveCD
No root device found, boot has failed using lxde liveCD
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
12
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-06 14:09 EDT by Brock Organ
Modified: 2013-01-10 00:30 EST (History)
6 users (show)

See Also:
Fixed In Version: 004-4.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-27 19:53:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot showing livecd error after selecting "boot" option (9.03 KB, image/png)
2009-10-06 14:09 EDT, Brock Organ
no flags Details
dmesg output (53.95 KB, text/plain)
2009-10-19 10:36 EDT, Arkady L. Shane
no flags Details

  None (edit)
Description Brock Organ 2009-10-06 14:09:44 EDT
Created attachment 363871 [details]
screenshot showing livecd error after selecting "boot" option

* testing using F12/qemu virtual machine
* nightly livecd compose
* lxde-x86_64-20090921.16.iso
* select "Boot" from livecd boot screen

during boot process, the liveCD fails and the screen shows an error (see attached screenshot) ...
Comment 1 Brock Organ 2009-10-06 14:18:07 EDT
this also affects lxde-i386-20090921.16.iso
Comment 2 Brock Organ 2009-10-06 14:55:56 EDT
desktop-i386-20090921.16.iso is also affected by this behavior ...
Comment 3 Matthias Clasen 2009-10-06 18:57:31 EDT
We should really get rid of the LiveCD component in bugzilla. It is not helpful...
Comment 4 Harald Hoyer 2009-10-07 04:40:06 EDT
desktop-i386-20091005.20.iso boots fine for me
Comment 5 Harald Hoyer 2009-10-07 07:34:29 EDT
ah, found the bug.. could reproduce it
Comment 6 Harald Hoyer 2009-10-07 10:21:52 EDT
Please try dracut-002-13.git8f397a9b.fc12

http://koji.fedoraproject.org/koji/buildinfo?buildID=135490

Also requested F-12 tag 
Ticket URL: <https://fedorahosted.org/rel-eng/ticket/2378>
Comment 7 Baif 2009-10-19 04:30:32 EDT
I'm trying to run F12 Beta LiveCD with Unetbootin.For F11, and F12-Alpha, it works. 

I tried F12-Beta x86-64 Live-KDE-CD and encountered this error "No root device found". I'm afraid of that I'll encounter this kind of problem in official beta release.

Please advice what should be done to fix this problem in Unetbootin

(In reply to comment #6)
> Please try dracut-002-13.git8f397a9b.fc12
> 
> http://koji.fedoraproject.org/koji/buildinfo?buildID=135490
> 
> Also requested F-12 tag 
> Ticket URL: <https://fedorahosted.org/rel-eng/ticket/2378>
Comment 8 Harald Hoyer 2009-10-19 06:58:06 EDT
(In reply to comment #7)
> I tried F12-Beta x86-64 Live-KDE-CD and encountered this error "No root device
> found". 

When do you see this? While starting the CD or after installation?
Comment 9 Arkady L. Shane 2009-10-19 09:31:29 EDT
Yes, this bug is present in 12-Beta. I tried to boot from cd (i686) on i915 laptop. After loading kernel I've got a message "No root device found", "Boot has failed, sleeping forever".
Comment 10 Harald Hoyer 2009-10-19 09:42:27 EDT
please add "rdinitdebug rdshell" to the kernel command line.

- you will get a shell
- mount /boot by hand
- output "dmesg" to a file on /boot, or copy over /init.log
- attach the file here
Comment 11 Arkady L. Shane 2009-10-19 10:04:19 EDT
Hm, keyboard does not work. Last messages:

+ echo
+ getarg rdshell
+ set +x

Dropping to debug shell.
sh: can't access tty; job control turned off
#
Comment 12 Harald Hoyer 2009-10-19 10:16:22 EDT
Ok, then plymouth is too old on this CD... 
add "rdinitdebug rdshell rd_NO_PLYMOUTH"
Comment 13 Baif 2009-10-19 10:34:13 EDT
(In reply to comment #8)
> (In reply to comment #7)
> > I tried F12-Beta x86-64 Live-KDE-CD and encountered this error "No root device
> > found". 
> 
> When do you see this? While starting the CD or after installation?  

Starting the CD. Actually I "burned" the CD into USB stick with Unetbootin. I haven't got the Live CD work.
Comment 14 Arkady L. Shane 2009-10-19 10:36:32 EDT
Created attachment 365241 [details]
dmesg output
Comment 15 Harald Hoyer 2009-10-19 10:50:23 EDT
The kernel command line parameter for root is

root=live:CDLABEL=F12-Beta-i686-Live

so, is your iso9600 labeled with "F12-Beta-i686-Live"
Comment 16 Arkady L. Shane 2009-10-19 10:56:38 EDT
Yes:

$ ls -l /dev/disk/by-label/ | grep sr
lrwxrwxrwx 1 root root  9 Окт 19 18:54 F12-Beta-i686-Live -> ../../sr0

This is official Beta what will be available on mirrors tomorrow.
Comment 17 Baif 2009-10-19 10:58:20 EDT
(In reply to comment #15)
> The kernel command line parameter for root is
> 
> root=live:CDLABEL=F12-Beta-i686-Live
> 
> so, is your iso9600 labeled with "F12-Beta-i686-Live"  

em. Got the shell with "rdinitdebug rdshell rd_NO_PLYMOUTH", and I guess that's because I don't have any device file for that label, even the dir /dev/by-label.

The dracut is dracut-002-13.4.git8f397a9b.fc12.

I do remember before F12 Beta, the root device was identified by UUID in the parameters generated by Unetbootin.
Comment 18 Harald Hoyer 2009-10-19 11:12:03 EDT
(In reply to comment #17)
> (In reply to comment #15)
> > The kernel command line parameter for root is
> > 
> > root=live:CDLABEL=F12-Beta-i686-Live
> > 
> > so, is your iso9600 labeled with "F12-Beta-i686-Live"  
> 
> em. Got the shell with "rdinitdebug rdshell rd_NO_PLYMOUTH", and I guess that's
> because I don't have any device file for that label, even the dir
> /dev/by-label.
> 
> The dracut is dracut-002-13.4.git8f397a9b.fc12.
> 
> I do remember before F12 Beta, the root device was identified by UUID in the
> parameters generated by Unetbootin.  

typo? "/dev/by-label" vs "/dev/disk/by-label" ?

you said, you booted from a USB stick.. is this stick labeled 
"F12-Beta-i686-Live" ?
Comment 19 Harald Hoyer 2009-10-19 11:14:10 EDT
(In reply to comment #16)
> Yes:
> 
> $ ls -l /dev/disk/by-label/ | grep sr
> lrwxrwxrwx 1 root root  9 Окт 19 18:54 F12-Beta-i686-Live -> ../../sr0
> 
> This is official Beta what will be available on mirrors tomorrow.  

is this in the rescue shell?
Comment 20 Baif 2009-10-19 11:20:29 EDT
(In reply to comment #18)
> (In reply to comment #17)
> > (In reply to comment #15)
> > > The kernel command line parameter for root is
> > The dracut is dracut-002-13.4.git8f397a9b.fc12.
> > 
> > I do remember before F12 Beta, the root device was identified by UUID in the
> > parameters generated by Unetbootin.  
> 
> typo? "/dev/by-label" vs "/dev/disk/by-label" ?
> 
> you said, you booted from a USB stick.. is this stick labeled 
> "F12-Beta-i686-Live" ?  

Yes it's typo.Sorry, my mistake.

I changed the syslinux.cfg(generated by Unetbootin), and the LiveCD is running. :) 

Thanks!!! 

Should it be a bug?
Comment 21 Arkady L. Shane 2009-10-19 11:31:57 EDT
No, this is on other host, where this cd is mounted. In the rescue shell there
is not any mention (by-label or by-uuid) about CD.

I tried to boot this CD in VirtualBox and on other host, and livecd booted
without errors.
Comment 22 Baif 2009-10-19 11:50:29 EDT
(In reply to comment #21)
> No, this is on other host, where this cd is mounted. In the rescue shell there
> is not any mention (by-label or by-uuid) about CD.
> 
> I tried to boot this CD in VirtualBox and on other host, and livecd booted
> without errors.  

You did burned it into a CD, right?
My question is that is the label "F12-Beta-i686-Live" too long for CD ISO9660 format?
Comment 23 Arkady L. Shane 2009-10-19 12:04:09 EDT
(In reply to comment #22)
I burned it via nautilus-brasero as always. On other host the system boots successful.
Comment 24 Baif 2009-10-19 12:13:01 EDT
(In reply to comment #23)
> (In reply to comment #22)
> I burned it via nautilus-brasero as always. On other host the system boots
> successful.  

OK. That's the problem, there is no such device file (/dev/disk/by-label/required by the parameters of  F12 Beta for booting up LiveCD :), on i915 main board.

I'm running it on ThinkPad x61 laptop 767529C (Intel GM965):
USB Controller: Intel 82801H (ICH8 Family)
STAT Controller: Intel 82801HBM/HEM (ICH8M/ICH8-E) SATA AHCI. 

Yet another problem with Intel chipset.
F12 Beta just got OPENGL desktop effects work for KDE 4.3 :)
Comment 25 Bug Zapper 2009-11-16 08:19:43 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 26 Fedora Update System 2010-01-26 05:48:59 EST
dracut-004-4.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/dracut-004-4.fc12
Comment 27 Fedora Update System 2010-01-26 20:06:08 EST
dracut-004-4.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dracut'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-1088
Comment 28 Fedora Update System 2010-01-27 19:51:28 EST
dracut-004-4.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.