This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 52752 - random persistent segmentation faults
random persistent segmentation faults
Status: CLOSED DUPLICATE of bug 48367
Product: Red Hat Linux
Classification: Retired
Component: xinetd (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-28 14:25 EDT by Zenon Mousmoulas
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-28 14:25:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Zenon Mousmoulas 2001-08-28 14:25:44 EDT
Description of problem:

At random times, xinetd persistently segfaults whenever it tries to spawn 
a new process to start a service upon a new connection. It's not 
reproducible, in my experience it just happens at about 30 hours intervals.
The segfaulting is persistent, meaning that when this happens, every new 
process xinetd tries to spawn upon will crash. The amount of time during 
which this segfaulting persists will vary, from own experience it can be 
anywhere from 15 to 90 minutes at a time. You can stop this segfaulting 
behavior if you restart xinetd.
This problem applies to xinetd-2.3.0-1.71 from 7.1 Errata. I don't know if 
it applies to xinetd-2.1.8.9pre14-6 that comes with the 7.1 distribution.

Version-Release number of selected component (if applicable):
2.3.0-1.71

How reproducible:
Couldn't Reproduce

Steps to Reproduce:


Additional info:

While the segfaulting persists, upon every new connection to a xinetd 
service, a set of messages like the ones below is logged via syslog 
in /var/log/messages:

Aug 28 20:22:24 gaulois xinetd[21846]: {general_handler} (21846) 
Unexpected signal: 11 (Segmentation fault)
Aug 28 20:22:24 gaulois last message repeated 9 times
Aug 28 20:22:24 gaulois xinetd[21846]: {bad_signal} Received 10 signals in 
1 seconds. Exiting...

Suggestions:

In the "Recent Changes" changelog for xinetd available at 
http://www.xinetd.org/#changes, under version 2.3.1, I read:

* Attempt to fix segfaulting seen since 2.3.0. -Steve Grubb

I could not locate any other information regarding this issue on xinetd 
web site. I am not sure whether this fix refers to the same problem I am 
reporting and I do not know if the problem has been actually fixed since 
the 2.3.1 release, but perhaps it would be a good idea to release a new 
updated rpm with the latest version (2.3.2) in errata, since this version 
also fixes other important bugs.
Comment 1 Zenon Mousmoulas 2001-08-28 17:49:46 EDT

*** This bug has been marked as a duplicate of 48367 ***

Note You need to log in before you can comment on or make changes to this bug.