Bug 52755 - init script leaves a stray lock file upon failure
Summary: init script leaves a stray lock file upon failure
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: autofs (Show other bugs)
(Show other bugs)
Version: roswell
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-28 18:46 UTC by Paul Iadonisi
Modified: 2007-04-18 16:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-28 19:12:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Paul Iadonisi 2001-08-28 18:46:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010803

Description of problem:
If you attempt to start autofs with the supplied init script when there are
no autmount points define (e.g.: /etc/auto.master is
absent), then an autofs lock file is created in /var/lock/subsys which
prevents autofs from starting until this file is manually removed or
upon the next reboot.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install autofs package
2.Rename /etc/auto.master to /etc/auto.master.save
3.Start autofs with 'service autofs start'
4.Check for service (ps auxww | grep automount) -- it won't be running
5.Rename /etc/auto.master.save back to /etc/auto.master
6.Attempt to start the service again with 'service autofs start'
7.Check for service (ps auxww | grep automount) -- it won't be
  running, even with valid automount points specified in auto.master
	

Actual Results:  The automounter didn't start after the first attempt
failed (not
a true failure -- no mount points specified).

Expected Results:  The init script should detect when there are no mount
points to run
the automounter with and not create a lock file since the automounter
should be running in this case.

Additional info:

Comment 1 Nalin Dahyabhai 2001-08-29 15:48:50 UTC
This should be fixed in autofs-3.1.7-21 and later.  Thanks!


Note You need to log in before you can comment on or make changes to this bug.