Bug 527553 - failed to stat() /dev/mapper/no /dev/mapper/raid /dev/mapper/disks
failed to stat() /dev/mapper/no /dev/mapper/raid /dev/mapper/disks
Status: CLOSED DUPLICATE of bug 527726
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12Target
  Show dependency treegraph
 
Reported: 2009-10-06 18:05 EDT by Nicolas Mailhot
Modified: 2014-03-16 23:20 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-07 11:34:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
boot logs (4.23 KB, text/plain)
2009-10-06 18:06 EDT, Nicolas Mailhot
no flags Details
system logs (79.46 KB, text/plain)
2009-10-06 18:06 EDT, Nicolas Mailhot
no flags Details
dmesg (49.60 KB, text/plain)
2009-10-06 18:07 EDT, Nicolas Mailhot
no flags Details
lspci (192.97 KB, text/plain)
2009-10-06 18:07 EDT, Nicolas Mailhot
no flags Details

  None (edit)
Description Nicolas Mailhot 2009-10-06 18:05:42 EDT
In boot logs:

mdadm: /dev/md0 has been started with 2 drives.
failed to stat() /dev/mapper/no
failed to stat() /dev/mapper/raid
failed to stat() /dev/mapper/disks

Version-Release number of selected component (if applicable):
kernel-2.6.31.1-56.fc12.x86_64
dracut-002-12.git8f397a9b.fc12.noarch
mdadm-3.0.2-1.fc12.x86_64
Comment 1 Nicolas Mailhot 2009-10-06 18:06:07 EDT
Created attachment 363908 [details]
boot logs
Comment 2 Nicolas Mailhot 2009-10-06 18:06:37 EDT
Created attachment 363909 [details]
system logs
Comment 3 Nicolas Mailhot 2009-10-06 18:07:00 EDT
Created attachment 363910 [details]
dmesg
Comment 4 Nicolas Mailhot 2009-10-06 18:07:30 EDT
Created attachment 363911 [details]
lspci
Comment 5 Harald Hoyer 2009-10-07 03:20:26 EDT
(In reply to comment #2)
> Created an attachment (id=363909) [details]
> system logs  

Oct 6 23:43:55 kernel: dracut: dracut-002-8.git845dd502.fc12


Please recreate your initramfs image
Comment 6 Zdenek Kabelac 2009-10-07 07:47:12 EDT
Well the bug is pretty clear IMHO.

There is no need for initramfs.

Clear bug is in /etc/rc.d/rc.sysinit

Output of dmraid is passed to for cycle. And if three is no raid - output of dmraid -s -c - i 'no raid disk' is being cycled through loop. Older version of this script contained egrep for ^no -

Me just wondering who made this optimization....
Comment 7 Bill Nottingham 2009-10-07 11:34:27 EDT

*** This bug has been marked as a duplicate of bug 527726 ***

Note You need to log in before you can comment on or make changes to this bug.