Bug 52758 - USB mouse not detected in installer
USB mouse not detected in installer
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks: 61901
  Show dependency treegraph
 
Reported: 2001-08-28 15:15 EDT by Michael E Brown
Modified: 2014-03-16 22:23 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-28 14:37:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael E Brown 2001-08-28 15:15:16 EDT
Description of Problem:
We have USB Keyboard here that has a PS/2-style mouseport on it. You plug a
PS/2 mouse in, and the keyboard makes the system see a USB mouse. This
mouse is not detected in the installer. This may be related to Hotplug bug
@ http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=52546

Normal USB mice are detected OK with USB mouse plugged into system.

[root@localhost root]# cat /proc/bus/usb/devices
T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=12  MxCh= 2
B:  Alloc=236/900 us (26%), #Int=  2, #Iso=  0
D:  Ver= 1.00 Cls=09(hub  ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=0000 ProdID=0000 Rev= 0.00
S:  Product=USB UHCI Root Hub
S:  SerialNumber=ef80
C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr=  0mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   8 Ivl=255ms
T:  Bus=01 Lev=01 Prnt=01 Port=01 Cnt=01 Dev#=  3 Spd=1.5 MxCh= 0
D:  Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=04f2 ProdID=0112 Rev= 1.03
S:  Manufacturer=CHICONY
S:  Product=USB Keyboard
C:* #Ifs= 2 Cfg#= 1 Atr=a0 MxPwr= 74mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=03(HID  ) Sub=01 Prot=01 Driver=hid
E:  Ad=81(I) Atr=03(Int.) MxPS=   8 Ivl= 10ms
I:  If#= 1 Alt= 0 #EPs= 1 Cls=03(HID  ) Sub=01 Prot=02 Driver=hid
E:  Ad=82(I) Atr=03(Int.) MxPS=   8 Ivl= 10ms
Comment 1 Bill Nottingham 2001-08-28 16:21:17 EDT
So... are you willing to have it claim there's a mouse there even when there isn't?
Comment 2 Michael E Brown 2001-08-28 16:42:00 EDT
I don't understand. Can you elaborate a bit?
Comment 3 Bill Nottingham 2001-08-28 16:52:43 EDT
Look at /proc/bus/usb/devices, both with the mouse plugged into the keyboard,
and without the mouse plugged into the keyboard - are they identical?
Comment 4 Michael E Brown 2001-08-28 17:02:35 EDT
Yes, they are identical.

I may be overlooking something, but I fail to see how this would cause any
adverse reactions by anything.

So, unless there is something I don't know about, yes, I am willing to have it
claim there is a mouse there whenever this keyboard is plugged in.

Right now, the installer doesn't work anyway, because even if there is a mouse
plugged in, the installer doesn't see it. Hotplug has been fixed to detect this
mouse (see bugzilla # above).

Comment 5 Michael Fulbright 2001-08-28 19:42:07 EDT
The mouse does not show up as a USB device if I am reading this correctly.

On any installed system does the mouse work?  If so, what are the contents of
/proc/bus/usb/devices?


Comment 6 Michael E Brown 2001-08-29 09:35:25 EDT
The mouse works just fine on an installed system if you load "mousedev". The
hotplug scripts weren't detecting it correctly if you hotplugged it (#52546),
but that has since been fixed.
Comment 7 Michael E Brown 2001-08-29 16:18:47 EDT
I forgot to mention that the cat /proc/bus/usb/devices at the beginning of the
bugzilla entry was taken from a running system, but it looks exactly the same in
the installer.
Comment 8 Bill Nottingham 2001-08-29 22:38:00 EDT
Well, among other things, if we changed this, and you attached this keyboard to
a machine with no mouse, the installer would try to start X. :)
Comment 9 Michael E Brown 2001-08-30 11:21:35 EDT
Well, as it is, it is even more broken than that. You cannot tell the system you
do have a mouse when you do, so there is no way to get into X in the first place.

Basically, people who don't have a mouse already have a workaround, and that
workaround is to type "linux text" at the boot prompt. People who _do_ have a
mouse have no way to tell the system this.

I would rather have the installer load "mousedev" and assume a mouse is present,
write a "readme" that says if you don't have a mouse, type "linux text" at the
boot prompt, than take customer support calls because their mouse doesn't work
in the installer.

Basically, Dell will take more customer support calls if we don't have this
feature than if we do. That is bad.
Comment 10 Michael Fulbright 2001-08-31 10:59:14 EDT
Its really too late to change this at this point, we're days from shipping.

There is a workaround which is to do a text mode install.

We can attempt to address this the next release cycle.

Somehow a dell employee got assigned this bug, reassigning to Bill since this is
a kudzu issue.
Comment 11 John A. Hull 2002-03-15 17:51:01 EST
Not detecting mouse in Hampton Beta 2.
Comment 12 Pete Zaitcev 2002-03-21 15:34:07 EST
I cannot believe this is not getting traction since August.
If that helps, I've got two Dell keyboards that they sent me.
Bill, do you want them? Otherwise those are pretty good keyboards.
Comment 13 Bill Nottingham 2002-04-03 11:33:21 EST
Fixed in kudzu-0.99.49-1... RPMS are at http://people.redhat.com/notting/kudzu/,
if you want to look before it hits rawhide.
Comment 14 Michael E Brown 2002-04-03 11:51:53 EST
Sorry Bill, but I'm not quite following here. Does this new kudzu RPM fix the
installer (anaconda) issue? How can I use the RPMS on your site to test the
installer? I'd be very happy to get this tested if you can tell me how...
Comment 15 Bill Nottingham 2002-04-03 11:55:40 EST
It will fix the anaconda issue once the loader is rebuilt against that
kudzu-devel, and the new kudzumodule is put in the second stage... basically, to
test anaconda, you'd need to add the kudzu packages to your tree and remake the
install images.
Comment 16 Jeremy Katz 2002-04-04 01:39:17 EST
And for your convenience, I've quickly put together a bootnet and update disk
that should work with the beta released today on ftp.beta at
http://people.redhat.com/~katzj/usbmouse so that you don't have to build your
own trees for testing.
Comment 17 Michael E Brown 2002-04-04 16:05:23 EST
Tried out the bootnet.img/updates.img file posted by katzj and they work like a
charm. Thanks.

Note You need to log in before you can comment on or make changes to this bug.