Bug 52766 - Some ethernet cards fail on DHCP lookup in 0827.1 but are fine in 7.1
Summary: Some ethernet cards fail on DHCP lookup in 0827.1 but are fine in 7.1
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-28 20:15 UTC by Zeke Harris
Modified: 2007-04-18 16:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-31 23:05:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Zeke Harris 2001-08-28 20:15:27 UTC
Description of Problem:
Some cards (so far, all of them have been using tulip) fail to get their IP
addresses from a DHCP server in 0815.1 - 0827.1. I've checked those two
builds only, haven't checked Roswell2 or anything earlier, but it's broken
in those. 

Tested for i386.

Version-Release number of selected component (if applicable):


How Reproducible:
If it don't work, it don't work. Some cards require a second try and they
get it, others just don't at all.

Steps to Reproduce:
1. start an install with bootnet 
2. have an affected adapter 
3. try to use DHCP and watch it fail, every time

Actual Results:
DHCP doesn't work

Expected Results:
DHCP should work


Additional Information:
   Affected Cards:
        Adapter            Chipset             Driver
        SMC EtherPower    (DEC 21041-AA)       tulip
        SMC EtherPowerII  (DEC 21041-PB)       tulip
        DEC DE435         (DEC 21040-AA)       tulip

Comment 1 Zeke Harris 2001-08-28 22:06:23 UTC
Only a problem with multi-port adapters (like those with both 10base-T and
10-base2, etc). Tou Anaconda folks know what's wrong better than I do... I
gather that it seems to be a boot kernel or driver issue. 

lspci -n output for the DE435:

Class 0200: 1011:0002 (rev 23)

Comment 2 Bill Nottingham 2001-08-28 22:10:01 UTC
What happens if you use the tulip_old driver?

Comment 3 Michael Fulbright 2001-08-29 16:51:51 UTC
Moving to NEEDINFO.

Comment 4 Glen Foster 2001-08-29 18:21:21 UTC
Look into having the driver on a separate driver disk and have the installer
load that driver from the disk.  That may be the only way to check this...

Comment 5 Zeke Harris 2001-08-29 20:52:48 UTC
tulip_old works, on the second try (first one kicks you back to the IP config.
screen, second puts you into the server name/folder screen).

Comment 6 Michael Fulbright 2001-08-31 15:02:51 UTC
Does this defect occur with RC2?

Comment 7 Zeke Harris 2001-08-31 23:05:24 UTC
Tulip (by itself) works for those cards now (as far as I can tell anyway, and
now = RC2, 0830). Cool.

"* pump told us: No DHCP reply recieved
* reverse name lookup worked"

then kicks me into server name/directory. Looks good to me.

Comment 8 Michael Fulbright 2001-09-05 18:51:24 UTC
Marking as working.


Note You need to log in before you can comment on or make changes to this bug.