Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 527674 - avahi-dnsconfd initscript lsb compliance
Summary: avahi-dnsconfd initscript lsb compliance
Keywords:
Status: CLOSED DUPLICATE of bug 600430
Alias: None
Product: Fedora
Classification: Fedora
Component: avahi
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: InitScriptsProject 584761
TreeView+ depends on / blocked
 
Reported: 2009-10-07 10:37 UTC by Yulia Kopkova
Modified: 2010-06-25 01:42 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 584761 (view as bug list)
Environment:
Last Closed: 2010-06-25 01:42:55 UTC
Type: ---


Attachments (Terms of Use)

Description Yulia Kopkova 2009-10-07 10:37:57 UTC
Description of problem:


1. Start of already started avahi-dnsconfd service should return 0
# service avahi-dnsconfd status ; echo $?
Avahi DNS daemon is running
0
# service avahi-dnsconfd start ; echo $?
Starting Avahi DNS daemon...                               [FAILED]
1
now: 1
expected: 0

2. Stop of already stopped avahi-dnsconfd should return 0
# service avahi-dnsconfd stop ; echo $?
Shutting down Avahi DNS daemon:                            [  OK  ]
0
# service avahi-dnsconfd stop ; echo $?
Shutting down Avahi DNS daemon:                            [FAILED]
1
now: 1
expected: 0

3. Status of stopped avahi-dnsconfd should return 3
# service avahi-dnsconfd stop ; echo $? 
Shutting down Avahi DNS daemon:                            [  OK  ]
0
# service avahi-dnsconfd status ; echo $? 
Avahi DNS daemon is not running
1
now: 1
expected: 3

4. Status of stopped avahi-dnsconfd with /var/lock/subsys/avahi-dnsconfd present:
# touch /var/lock/subsys/avahi-dnsconfd
# service avahi-dnsconfd status ; echo $?
Avahi DNS daemon is not running
1
now: 1
expected: 2

5. Init script should return code "4" if restarting service under
nonprivileged user:
# su testuserqa -c "service $SERVICE restart"; echo $?
restart: unrecognized service
1
now: 1 
expected: 4 
 
6. force-reload action should be supported

7. reload action is not documented
# service avahi-dnsconfd statusasd ; echo $?
Usage: /etc/init.d/avahi-dnsconfd {start|stop|status|restart|condrestart}
2
# service avahi-dnsconfd reload ; echo $?
Reloading Avahi DNS daemon...                              [  OK  ]
0

Comment 1 Bug Zapper 2009-11-16 13:21:21 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 3 Lennart Poettering 2010-06-25 01:42:55 UTC

*** This bug has been marked as a duplicate of bug 600430 ***


Note You need to log in before you can comment on or make changes to this bug.