Bug 52768 - kernel crash during normal usage
kernel crash during normal usage
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-28 16:34 EDT by craigl
Modified: 2008-08-01 12:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:39:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log containing the /var/log/messages of the most recent crashes (32.81 KB, text/plain)
2001-08-28 16:43 EDT, craigl
no flags Details
/var/log/messages for latest crash(es) (4.85 KB, text/plain)
2001-08-29 22:03 EDT, craigl
no flags Details
latest crash log (3.61 KB, text/plain)
2001-09-05 01:29 EDT, craigl
no flags Details

  None (edit)
Description craigl 2001-08-28 16:34:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-12 i586)

Description of problem:
ever since upgrading my system to redhat-7.1, i am expreience very annoying
and regular system crashes.  normally, this is in the X process (as seen in
the attachment) but it can happen in other processes also.  sometimes, i
get the following message:

  kernel BUG at page_alloc.c:82

but normally, it is similar to what you see in the log in the attachment.

this is, in fact, the third attempt at entering this bug.  the system
crashed the previous two times before i could complete it...

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. load up evolution
2. load up galeon
3.  start using it
	

Actual Results:  crash

Expected Results:  not crashed ;-)

Additional info:
Comment 1 Arjan van de Ven 2001-08-28 16:42:18 EDT
can you past the output of lsmod ?
this looks like the bug in the nvidia binary only driver; are you using that ?
Comment 2 craigl 2001-08-28 16:43:48 EDT
Created attachment 29956 [details]
log containing the /var/log/messages of the most recent crashes
Comment 3 craigl 2001-08-28 16:45:29 EDT
[root@jigra /root]# lsmod
Module                  Size  Used by
tuner                   3952   0  (autoclean)
i2c-core               12640   0  (autoclean) [tuner]
emu10k1                45328   1  (autoclean)
soundcore               3408   4  (autoclean) [emu10k1]
nfs                    70720   1  (autoclean)
lockd                  47888   1  (autoclean) [nfs]
sunrpc                 55696   1  (autoclean) [nfs lockd]
ne                      6336   1  (autoclean)
8390                    5632   0  (autoclean) [ne]
ipchains               27648   0  (unused)
usb-uhci               19472   0  (unused)
usbcore                46656   1  [usb-uhci]
Comment 4 craigl 2001-08-28 16:47:46 EDT
sorry, i should have added:

no, i'm not using the nvidia driver.


however, i now notice that since i simply used netscape 4.77 insted of galeon to
try and create this bug, i have managed to create it and it seems to be working
ok.  i haven't started evolution yet either.  not sure if that's related or
not.  can it be?
Comment 5 Arjan van de Ven 2001-08-28 16:55:23 EDT
It shouldn't be. Can you give a bit more information about this system ?
eg cpu type, memory etc
Comment 6 craigl 2001-08-28 17:01:34 EDT
cpu: K6/2@500
vid: matrox millenium (x2, but this was happening before i added the second one)
mem: i actually have 4 configs i've been testing.  i have 2 128MB sticks and a
256MB stick.  normally, i have been running with one 128 and the 256, but i have
tried using only, trying both the 128 and the 256 separately.  still crashes in
a very similar manner.
Comment 7 Arjan van de Ven 2001-08-29 10:31:35 EDT
I think I found a codebug; I'm building a new kernel with a patch and I hope
you're willing to test that to see if it fixes it.
Comment 8 craigl 2001-08-29 11:14:51 EDT
you betcha i'm willing to try it.  all the sensitive data is being back up
hourly, just in case.  i'd HATE to have to reinstall an older version...

thanks!
Comment 9 Arjan van de Ven 2001-08-29 13:14:00 EDT
Ok the i586 kernel is done, the i686 one is still building (there is a bit of a
queue in the buildsystem and I had to build on my workstation), the kernel is
versioned 2.4.3-18 and can be found at

http://people.redhat.com/arjanv/testkernels/

Comment 10 craigl 2001-08-29 14:15:20 EDT
ok, new kernel installed and currently operating.  so far, it looks very good. 
i will keep y'all informed.

couple points:
1) is it ok that i'm using a K6/2 and this is an i586 kernel?

2) there was one case that seemed to trigger a crash somewhat regularly.  while
using galeon, if i tried resizing and/or scrolling while the page was still
loading, it seemed to crash the system more frequently.  just now, while loading
the bugquery page ( takes a nice relatively long time to load up and layout the
form ) i tried scrolling around.  i had galeon crash, but this time it just sat
with a unupdated window.  normally, when it crashes i get a little dialog box
popup, this was the very first time i've had it just stop updating.  SO, that
gives me a very good feeling about this update.

thank you so very much for your incredibly prompt and helpful attention to this
matter.  i promise i will report any thing i find as soon as it happens.

now, i'm off to try and get some work done!
Comment 11 craigl 2001-08-29 21:58:49 EDT
hmm, had a similar crash this afternoon, i will attach the relevant log
separately.  when this happened, the machine was doing too much.  i had left it
for a little while.  when i came back, i had been dropped back to the gdm login
screen.

i am still convinced it seems better though.

let me know if there is anything else i can do.
Comment 12 craigl 2001-08-29 22:03:32 EDT
Created attachment 30174 [details]
/var/log/messages for latest crash(es)
Comment 13 craigl 2001-09-05 01:27:26 EDT
after using my machine again for less than two hours, it once again crashed.  i
have attached the log from a crash on thursday before i took off for the
weekend, then the one from this evening.

i really do need to try and be able to actually work.  i'm seeing what i can do
about compiling the 2.2.19 kernel from kernel.org for myself to use, as well as
2.4.9 to see if that helps.

if there is still anyone working on this, i will still be willing to try new
kernels if need be, i just can't be having crashes every 2-6 hours, its just too
painful.
Comment 14 craigl 2001-09-05 01:29:06 EDT
Created attachment 30909 [details]
latest crash log
Comment 15 Bugzilla owner 2004-09-30 11:39:08 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.