Bug 52770 - Kernel Panic on boot after install
Kernel Panic on boot after install
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-28 17:38 EDT by Pete Molina
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 13:22:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pete Molina 2001-08-28 17:38:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0b; Windows NT 5.0)

Description of problem:
after installing roswell booting produces errors then a kernel panic

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install roswell
2.boot pc
3.
	

Actual Results:  ends in a kernel panic

Expected Results:  boot into OS

Additional info:

i have tried loading it as a fresh install and as an upgrade to 7.1 and 
both produce the Exact same errors and kernel panic. the install goes 
great.. here are the errors i get..

Mounting root filesystem
hda1: Bad Access: block=2, count=2
end request: i/o error, dev 03:01 (hda) sector 2
EXT2-FS: unable to read superblock
mount: error 22 mounting ext2
pivotroot: pivot_root(sysroot,/sysroot.initrd)failed 2
freeing unused kernel memory: 232k freed
Kernel Panic: no init found. try passing init= option to kernel

and there is where it sits...here is a description of the pc..

Asus CUSL2 MB
intel 933 mhz
256mb ram
adaptec 2940 scsi
intel pro100 nic
tnt2 pci vid card
40x cdrom
Maxtor 80GB hd
ide zip

the HD is the only new factor on this PC, i have had RH 7.1 loaded on this 
pc before with a different HD and with this new one.. without a problem..
Comment 1 Arjan van de Ven 2001-08-28 17:43:55 EDT
Does this motherboard have a promise raid card and do you have a disk attached
to that ?
Comment 2 Pete Molina 2001-08-29 07:13:46 EDT
NO.. no promise raid controller..  i have been contemplating using a ultra 100 
card...  but as of yet.. the configuration is only what i posted.. im using the 
on-board IDE controllers..
Comment 3 Pete Molina 2001-08-29 09:52:40 EDT
OK.. i got it loaded by putting in an old 6gb harddrive i had.. RH7.1 loads 
fine on the 80GB..but i guess for some reason roswell does not like something 
about the 80GB ide....
Comment 4 Pete Molina 2001-08-30 09:44:11 EDT
NOW.. here is another problem.... i tried installing roswell in one of my home
pc's that has been running RH 7.1 with out a problem.. guess what i got..the
exact kernel panic messages i got on my work test PC..  this one also has no
promise raid controller.. here is the pc configuration

Asus P4 MB
intel 1.4 ghz
intel pro 100
sound blaster live sb
384mb ram
IBM 45GB harddrive
hercules Geforce 2 GTS 32mb vid card.
plextor cdr

is there a limitation to how big the / partition should be...?? i made the
partition the same size i had with 7.1..  since i have larger drives i usually
run large partitions...here is what i had..

/ = 5gb
/usr = 8gb 
/var = 8gb
swap = 1gb
/home = 23gb
Comment 5 Arjan van de Ven 2001-08-30 09:54:17 EDT
Is there any way you can install the 2.4.7-2.18 kernel from
http://people.redhat.com/arjanv/testkernels/i686

(eg rescue mode)
and see if that works ?
Comment 6 Pete Molina 2001-08-31 14:55:40 EDT
ok..  let me give it a shot.. i downloaded the 2.4.7-2.19 since that is the one 
there..  im finishing up a fresh install of roswell on the 80gb drive and will 
give the new kernel a shot.
Comment 7 Pete Molina 2001-09-01 13:44:55 EDT
cool..  got the home pc running with roswell and kernel 2.4.7-2.19 ....  i will
try this on the work test pc next...  thanks for you help

Note You need to log in before you can comment on or make changes to this bug.