Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 527714 - Entering a non-numeric capacity creates a volume with 10000 MB
Summary: Entering a non-numeric capacity creates a volume with 10000 MB
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: 11
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F11VirtTarget
TreeView+ depends on / blocked
 
Reported: 2009-10-07 13:00 UTC by Darryl L. Pierce
Modified: 2015-06-22 00:07 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-01 23:39:32 UTC
Type: ---


Attachments (Terms of Use)

Description Darryl L. Pierce 2009-10-07 13:00:10 UTC
Description of problem:
When creating a new storage volume for a pool, if I enter a non-numeric value into the max capacity field and click create then a volume is created with the previous numeric value that was in the capacity field.

Version-Release number of selected component (if applicable):
(mcpierce@mcpierce-laptop:~)$ rpm -qf `which virt-manager`
virt-manager-0.8.0-3.fc11.noarch

How reproducible:
100%

Steps to Reproduce:
1. Open virt-manager, go to details, go to storage tab
2. Click "New Volume"
3. Enter a non-numeric value in the max capacity field
4. Without leaving the field, click "Create Volume"
  
Actual results:
A volume is created that is the size of previous value in the capacity field.

Expected results:
An error message if the value was non-numeric. Or, if the current value is numeric then that value is used.

Additional info:

Comment 1 Cole Robinson 2009-12-01 23:39:32 UTC
I can't reproduce on rawhide: if you enter text in the box then click away, the box sets itself to 1, so maybe this was changed at the gtk level.

Either way, fixing this would require registering focus-in/out events AFAIUI, which I think is more trouble then its worth. Closing as WONTFIX.


Note You need to log in before you can comment on or make changes to this bug.