Bug 527733 - crash on startup with libmoblin
crash on startup with libmoblin
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-07 10:28 EDT by cje
Modified: 2010-08-23 15:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-23 15:40:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error log file (48.72 KB, application/octet-stream)
2009-10-07 10:28 EDT, cje
no flags Details

  None (edit)
Description cje 2009-10-07 10:28:22 EDT
Created attachment 363977 [details]
error log file

Description of problem:
with the moblin desktop installed i can't start eclipse.  i get the following error message:
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00219f87, pid=2149, tid=3085903552
#
# JRE version: 6.0-b16
# Java VM: OpenJDK Client VM (14.0-b16 mixed mode linux-x86 )
# Distribution: Custom build (Thu Sep 10 17:09:30 EDT 2009)
# Problematic frame:
# C  [libmoblin-netbook-engine.so+0x4f87]
#
# An error report file with more information is saved as:
# /home/whyoh/hs_err_pid2149.log
#
# If you would like to submit a bug report, please include
# instructions how to reproduce the bug and visit:
#   http://icedtea.classpath.org/bugzilla
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#


Version-Release number of selected component (if applicable):
eclipse-platform-3.5.0-2.fc12.i686
moblin-gtk-engine-1.0.1-2.fc12.i686

How reproducible:
always

Steps to Reproduce:
1.install rawhide
2.install moblin desktop
3.install eclipse
4.run eclipse
  
Actual results:
crash

Expected results:
eclipse IDE :-)

Additional info:
Comment 1 cje 2009-10-07 10:34:43 EDT
removing moblin-gtk-engine allows eclipse to start.
Comment 2 Andrew Overholt 2009-10-07 10:42:34 EDT
Could you try with a download from upstream and if it fails with that, too, file a bug at bugs.eclipse.org?  The SWT committers there will have a much better idea of where the problem lies.

Grab a .tar.gz from:

http://download.eclipse.org/eclipse/downloads/drops/R-3.5.1-200909170800/index.php

for your architecture, extract, and then run the included 'eclipse' binary.  If you have java-1.6.0-openjdk-devel installed, it should just work.

Thanks.
Comment 3 cje 2009-10-07 12:40:28 EDT
sorry, that downloaded eclipse crashes faster (with or without moblin-gtk-engine) with an error about /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/bin/../lib/i386/client/libjvm.so (which is from java-1.6.0-openjdk-1.6.0.0-31.b16.fc12.i686) and this in a pop-up window:

JVM terminated. Exit code=-1
-Xms40m
-Xmx256m
-XX:MaxPermSize=256m
-Djava.class.path=/home/whyoh/Downloads/eclipse//plugins/org.eclipse.equinox.launcher_1.0.201.R35x_v20090715.jar
-os linux
-ws gtk
-arch x86
-showsplash /home/whyoh/Downloads/eclipse//plugins/org.eclipse.platform_3.3.201.v200909170800/splash.bmp
-launcher /home/whyoh/Downloads/eclipse/eclipse
-name Eclipse
--launcher.library /home/whyoh/Downloads/eclipse//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_1.0.200.v20090520/eclipse_1206.so
-startup /home/whyoh/Downloads/eclipse//plugins/org.eclipse.equinox.launcher_1.0.201.R35x_v20090715.jar
-vm /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/bin/../lib/i386/client/libjvm.so
-vmargs
-Xms40m
-Xmx256m
-XX:MaxPermSize=256m
-Djava.class.path=/home/whyoh/Downloads/eclipse//plugins/org.eclipse.equinox.launcher_1.0.201.R35x_v20090715.jar
Comment 4 Andrew Overholt 2009-10-07 12:46:18 EDT
Can you attach the hs_err file from that failure?  If there wasn't one generated, can you run it with the arguments:

-debug -consolelog

and attach the output here?  Thanks.
Comment 5 Earle Nietzel 2009-11-01 00:47:21 EDT
This may be happening because of selinux denying permission.

Try running eclipse with selinux in permissive mode? 

setenforce 0

Then start eclipse.
Comment 6 cje 2009-11-02 18:51:24 EST
looks like all is okay again now.

eclipse-platform-3.5.1-1.fc12.i686
moblin-gtk-engine-1.0.2-1.fc12.i686

:-)

for the record - yes, setenforce 0 worked with the downloaded tarball version of eclipse.  thanks for that tip.
Comment 7 Bug Zapper 2009-11-16 08:22:13 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.