Bug 52778 - Oops [Kernel 2.4.2 from bootdisk floppy crashes]
Oops [Kernel 2.4.2 from bootdisk floppy crashes]
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-28 20:09 EDT by Harka
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 23:32:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harka 2001-08-28 20:09:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010802

Description of problem:
When booting with the 2.4.2 kernel from RedHat 7.1 on a Acer
Pentium-100/265k L2 with 64MB RAM and a Cirrus Logic 5430 graphics card
(1MB VRAM) the kernel crashes. Apparently it completely gets the wrong
picture about available memory and later Oopses. A test bootup with kernel
2.4.3 worked fine. Also Redhat 6.2 works. However, I don't know how to
create a bootdisk to get the CD installation going from scratch. So either
an updated bootdisk with a kernel later tha 2.4.2 or some advice on how to
create one would be appreciated, since the CD-ROM drive is not bootable.

Here are some relevant lines from the bootup screen:
Linux version 2.4.2-2BOOT (root@porky.devel.redhat.com) (gcc version 2.96
20000731 (RedHat Linux 7.1 2.96-79) #1 Sun Apr 8 18:24:33 EDT 2001
BIOS-provided physical RAM map:
BIOS-e801: 000000000009f000 @ 0000000000000000 (usable)
BIOS-e801: 0000000041505000 @ 0000000000010000 (usable)
Warning only 896MB will be used.
Use a HIGHMEM enabled kernel.
...
Memory: 899332k/917504k available (1193k kernel code, 17784k reserved, 84k
data, 108k init, 0k highmem)
...
ide0 at 0x1f0-0x1f7,0x3fx on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
Unable to handle kernel paging request at virtual address ffffff7f
printing eip:
c0145dc2
pgd entry c0101ffe:0000000000002063
pmd entry c0101ffe:0000000000002063
pte entry c0002ffc:0000000000000000
...pte not present!
Oops: 0002
CPU: 0
EIP: 0010:[<c0145dc2>]
EFLAGS: 00010282
eax: 00000000  ebx: ffffff7f  ecx:00000013  edx: f7fff010
esi: 00000000  edi: ffffff7f  ebp: 00008124  esp: c1f7bf0c
ds: 0018 es: 0018 ss: 0018
Process swapper (pid 1, stackpage=c1f7b000)
Stack: c0145e4d 000000008 c020b1b2 c023a850 c1f64490 c028cb80 0006e000 c018b6e9
c020b1b2 00008124 c1f64490 c028cb80 c028cb80 c0180188 c1f64490
c023a840 c028cb80 c1f64490 c0239d78 c028cb80 000000001 c028ce3c
Call Trace: [<c0145e4d>] [<c020b1b2>] [<c018b6e9>] [<c020b1b2>]
[<c0180188>] [<c018e925>] [<c01f9d60>] [<c0105000>] [<c01070d5>]
[<c0105000>] [<c01074fe>] [<c01070cc>]
Code: f3 ab 86 44 24 04 40 8d 53 4c 89 c1 8b 74 24 08 c1 e9 02 89
Kernel panic: Attempted to kill init!

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Probably system- and kernel-specific.

Additional info:

If more info is needed, such as the entire <dmesg> output let me know.

An updated bootdisk on updates.redhat.com would be awesome!
Comment 1 Harka 2001-08-28 20:15:30 EDT
Btw., adding the mem=64MB option to the boot: prompt did not make a difference.
Comment 2 Arjan van de Ven 2001-08-29 04:19:16 EDT
Try mem=62M as usually the last megabyte or so is reserved by the bios.
Comment 3 Harka 2001-08-29 16:06:17 EDT
Hi arjanv,

thanks for the quick response. Your suggestion worked...I tried it with mem=63m
and it booted fine for the first time. Out of interest, what would cause this?
And how would you suggest going about creating a bootdisk for a given kernel
(the BOOTDISK-HOWTO is not very clear in some parts...especially the compressed
initrd stuff. A better document by RedHat would certainly help many people.)

Thanks and take care...
Comment 4 Alan Cox 2002-12-15 23:32:18 EST
bios issue not Linux

Note You need to log in before you can comment on or make changes to this bug.