Bug 527808 - Sometimes my VMs won't start.
Sometimes my VMs won't start.
Status: CLOSED DUPLICATE of bug 515521
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-07 15:02 EDT by Zack Cerza
Modified: 2009-10-09 10:16 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-09 10:16:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zack Cerza 2009-10-07 15:02:58 EDT
Description of problem:
Sometimes when I try to start one of my VMs, I get an error dialog saying "Error starting domain: internal error unable to start guest: qemu: could not open serial device 'pty': No child processes" and showing this traceback:

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 571, in run_domain
    vm.startup()
  File "/usr/share/virt-manager/virtManager/domain.py", line 664, in startup
    self.vm.create()
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 293, in create
    if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: internal error unable to start guest: qemu: could not open serial device 'pty': No child processes

I'm not sure where to file this, but I'll start with libvirt...

Version-Release number of selected component (if applicable):
qemu-common-0.11.0-3.fc12.x86_64
kernel-2.6.31.1-56.fc12.x86_64
libvirt-0.7.1-10.fc12.x86_64
Comment 1 Mark McLoughlin 2009-10-09 09:33:21 EDT
Thanks for the report

Does the /dev/pts in entry in /etc/fstab contain 'gid=5,mode=620' ? See bug #515521
Comment 2 Zack Cerza 2009-10-09 10:16:48 EDT
Turns out that was the problem. Thanks!

*** This bug has been marked as a duplicate of bug 515521 ***

Note You need to log in before you can comment on or make changes to this bug.