Bug 527823 - Insmod error message is shown on power-on sequence.
Summary: Insmod error message is shown on power-on sequence.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen
Version: 5.4
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Don Dutile (Red Hat)
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks: 514490
TreeView+ depends on / blocked
 
Reported: 2009-10-07 19:54 UTC by Bill Braswell
Modified: 2018-10-27 13:46 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-10-25 09:30:48 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Bill Braswell 2009-10-07 19:54:37 UTC
Red Hat Enterprise Linux Version Number: Red Hat Enterprise Linux 5.4
Release Number: beta
Architecture: IA64
Kernel Version: 2.6.18-155.el5xen

Drivers or hardware or architecture dependency: PV driver

Insmod error message is displayed on power-on sequence.
"insmod: error inserting '/lib/xen-vbd.ko': -1 File exists"


This issue seems to be same as IT#240930, BZ473899
https://bugzilla.redhat.com/show_bug.cgi?id=473899
IT#240930 was already fixed on RHEL5.3.

Steps to Reproduce:
1. edit guest config file(etc/modprobe.conf)
    -----------------------------------------------
    alias scsi_hostadapter ata_piix
    alias eth0 xen-vnif                  <--- add
    alias scsi_hostadapter xen-vbd       <--- add
    -----------------------------------------------

2. create RAM disk image on guest domain
    guest # /sbin/mkinitrd -f <initrd-image> <kernel-version>

3. edit elilo.conf file
------------------------------------------------------------
prompt
timeout=20
default=xen-pv-on-hvm         <-- change from "linux" to "xen-pv-on-hvm"
relocatable

image=vmlinuz-2.6.18-155.el5
       label=linux
       initrd=initrd-2.6.18-155.el5.img
       read-only
       append="console=ttyS0,115200,8n1 rhgb quiet root=LABEL=/"
image=vmlinuz-2.6.18-155.el5     <-- add
       label=xen-pv-on-hvm      <-- add
       initrd=initrd-pvhvm-2.6.18-155.el5.img   <-- add
       read-only                <-- add
       append="console=ttyS0,115200,8n1 rhgb quiet root=LABEL=/ ide0=noprobe"  <-- add
------------------------------------------------------------

4. restart guest domain.

5. create RAM disk image on guest domain again.
    guest # /sbin/mkinitrd -f <initrd-image> <kernel-version>

6. restart guest domain again.

Procedure 5 and 6 are different from that of bz 473899

Comment 2 Don Dutile (Red Hat) 2009-10-08 16:10:30 UTC
Remove this line from the modprobe.conf file:

    alias scsi_hostadapter xen-vbd       <--- add

You should also blacklist the 8139cp & 8139too
(unless ia64 doesn't support them).

Comment 7 Paolo Bonzini 2010-06-22 17:16:59 UTC
Can we get the initrd after step 2 and after step 6?  These are unfortunately not included in the sosreport.

Also, the sosreport for the host is actually also for a guest.

Comment 9 Paolo Bonzini 2010-07-01 08:16:35 UTC
Yes, this information would be helpful.  No problem about the confusion.


Note You need to log in before you can comment on or make changes to this bug.