Bug 52786 - username/id terminology in interface and code is confusing
Summary: username/id terminology in interface and code is confusing
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-29 02:36 UTC by Matthew Miller
Modified: 2007-04-18 16:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-18 20:14:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matthew Miller 2001-08-29 02:36:12 UTC
Typically, "user id" refers to the numeric user id, and "user name" refers
to the account/login name. (See, for example, man 3 getpwnam). Dialog boxes
in anaconda use "User ID" to mean the name, not the number, which is
confusing -- especially since there is actually no way to set the numeric uid.

The code also has this problem -- it uses "id" to mean "user name" and
"name" to mean "gecos/real/full name". It would be good to change this to
"uid" and "gecosname" (or "fullname"?) to match more typical practice. This
would make the code a lot easier to follow -- and of course the actual
installation process as well.

I'm sure you're not eager to mess with this so late in the development
cycle, but please consider straightening this out for the next release.

Comment 1 Michael Fulbright 2001-08-29 16:51:16 UTC
Brent please look into for our next release.

Comment 2 Brent Fox 2001-08-29 18:51:34 UTC
Ok.  I'll look into it.  Deferring to a future release.

Comment 3 Brent Fox 2001-09-19 22:17:21 UTC
Fixed in CVS.


Note You need to log in before you can comment on or make changes to this bug.