Bug 527881 - Cannot 'Select all' or 'Update list' or navigate with arrows when comparing cloned channel to base channel (merge packages)
Summary: Cannot 'Select all' or 'Update list' or navigate with arrows when comparing c...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI
Version: 530
Hardware: All
OS: Linux
urgent
high
Target Milestone: ---
Assignee: Justin Sherrill
QA Contact: Brandon Perkins
URL:
Whiteboard:
Depends On:
Blocks: sat531-blockers
TreeView+ depends on / blocked
 
Reported: 2009-10-08 03:43 UTC by Xixi
Modified: 2018-10-27 16:00 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-20 15:37:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:1597 0 normal SHIPPED_LIVE Red Hat Network Satellite bug fix update 2009-11-20 15:37:02 UTC

Description Xixi 2009-10-08 03:43:34 UTC
Description of problem:
When attempting to compare and merge packages to a cloned channel from a base channel, customer cannot "Select all".

Version-Release number of selected component (if applicable):
Red Hat Network (RHN) Satellite 5.3.0

System architecture(s):
RHEL 4 32-bit

How reproducible:
Always.

Steps to Reproduce:
1. On a 5.3.0 Satellite, create a cloned channel of a RHEL Base Channel, start with original state of channel (no errata).
2. Click Channels-->Manage Software Channels-->(Cloned Channel Name)-->Packages-->Compare-->Select the Source/Original RHN Base Channel-->Compare-->Merge Differences-->Select "Make Identical..."--->Preview Merge-->Select All.

Actual results:
No packages are selected or the existing selection is cleared.

Expected results:
All packages are selected.

Additional info:
In what looks like another manifestation of the same issue, if you click on a few package checkboxes, then click "Update List", the selection also disappears.  Also, if you click a few checkboxes, then click the next arrow, the selection disappears as well.

Possible workaround:
RHN API call channel.software.mergePackages ?

Comment 2 Xixi 2009-10-08 03:47:43 UTC
This seems to have similar symptoms as bug 459445 although I've not found any conflicting set labels in this case, so maybe it's different after all...

Comment 4 Justin Sherrill 2009-11-03 15:56:38 UTC
Seem like commit ca6e20fbf897f351b67309ba175844a62ea39818 broke this.

Comment 5 Justin Sherrill 2009-11-03 16:37:53 UTC
fixed in spacewalk master: d3b314be46280dcc5099f64f8fd51c50b3c592a6

Comment 6 Justin Sherrill 2009-11-10 18:49:34 UTC
fixed in SATELLITE-5.3: ef7c741e52d792aa107f50caa0febfdd4ed10861

Comment 7 Garik Khachikyan 2009-11-19 08:27:00 UTC
#VERIFIED
Checked the fix with packages:
spacewalk-java-0.5.44-50.el[4,5]sat
spacewalk-java-lib-0.5.44-50.el[4,5]sat
spacewalk-java-config-0.5.44-50.el[4,5]sat
spacewalk-taskomatic-0.5.44-50.el[4,5]sat
spacewalk-moon-0.5.23-29.el[4,5]sat
spacewalk-grail-0.5.23-29.el[4,5]sat
spacewalk-base-minimal-0.5.23-29.el[4,5]sat
spacewalk-cypress-0.5.23-29.el[4,5]sat
spacewalk-html-0.5.23-29.el[4,5]sat
spacewalk-base-0.5.23-29.el[4,5]sat
spacewalk-sniglets-0.5.23-29.el[4,5]sat
spacewalk-pxt-0.5.23-29.el[4,5]sat

Checked against satellite installed with rhel5 and rhel4 (platform: i386).

Scenario described in issue's description is corrected now.

Comment 9 errata-xmlrpc 2009-11-20 15:37:06 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1597.html


Note You need to log in before you can comment on or make changes to this bug.