Bug 52791 - SiS X server buggy [Graphical elements offset in lowres install]
SiS X server buggy [Graphical elements offset in lowres install]
Status: CLOSED WONTFIX
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Brock Organ
http://www.ecs.com.tw/products/bookpc...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-28 23:38 EDT by Need Real Name
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-05 20:41:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-08-28 23:38:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)

Description of problem:
During a lowres install, many of the graphical elements are offset to the 
left and above where they belong. Typically radio buttons, check boxes, 
and pictures.

Example: on the installation progress screen, two elements are off. The 
overall progress bar is in the right location, but the graphic for the 
package progress bar is against the top of the screen, and about halfway 
to the left edge. The bottom two thirds of the red hat man are similarly 
offset, putting it against the left edge. On that screen, all other 
elements are correct.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Plug in CD and reboot
2.Select lowres install
3.Most screens after this have offset errors.
	

Actual Results:  Many graphical elements aren't where they should be. 
Behavior of the elements is correct, however (i.e. click where the 
checkbox is supposed to be).

Expected Results:  Clean layout

Additional info:

SiS 630
Normal install is OK
Comment 1 Michael Fulbright 2001-08-29 12:49:15 EDT
Brent please look into this.
Comment 2 Brent Fox 2001-08-31 11:08:54 EDT
I can't reproduce this.  Is this chip in a laptop?
Comment 3 Need Real Name 2001-08-31 11:25:43 EDT
Target system described at URL <http://www.ecs.com.tw/products/bookpc2.htm>. 
Spec'd at <http://www.ecs.com.tw/products/bookpc2-spec.htm>.
Comment 4 Brent Fox 2001-08-31 16:07:25 EDT
Weird.  What kind of monitor?
Comment 5 Need Real Name 2001-08-31 18:10:25 EDT
Doesn't matter. I've tried both an ancient GoldStar (mfg 1993, the reason for 
the lowres install in the first place) and a Samsung 17GLs (which successfully 
showed the normal install). Both showed the behavior. Boot said 'can't probe' 
for each.

More info: the large graphic on the initial splash screen is broken up, and the 
icons on the 'type of install' dialog are scattered all over the screen. Text 
is never boogered.
Comment 6 Brent Fox 2001-09-05 16:20:20 EDT
I'll try to find a SiS 630 in the test lab.  If we don't have one, I don't know
if I'll be able to do anything about this bug.  I don't see this behavior on
other cards.

Comment 7 Brent Fox 2001-09-05 17:21:12 EDT
I checked with the guys in the test lab, and we don't have anything with a SiS
630 in house.  I don't think this is a very high severity, since it only seems
to affect this one video card, and then only if you have a monitor that can't do
800x600, which are pretty rare these days.
Comment 8 Matt Wilson 2001-09-05 20:41:39 EDT
Nevertheless, this is an X bug or Cards file bug (if we need a noaccel option or
something).
Comment 9 Mike A. Harris 2001-10-22 02:00:17 EDT
I have disabled acceleration in the Cards file.  If someone wants
to experiment with the precice XAANo______ options that make this
problem go away, I can reenable acceleration, and just disable
the XAA primitives that are causing the problems.  Please reopen
this report if you determine which XAA features do not work.

Details for doing this are on the XF86Config man page.

Note You need to log in before you can comment on or make changes to this bug.