Bug 527966 - Xrandr black screen with r500 [NEEDINFO]
Summary: Xrandr black screen with r500
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-ati
Version: 5.3
Hardware: i386
OS: Linux
low
high
Target Milestone: rc
: ---
Assignee: Jérôme Glisse
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-08 12:23 UTC by g.puneet
Modified: 2014-06-02 13:08 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-02 13:08:36 UTC
Target Upstream Version:
pm-rhel: needinfo? (g.puneet)


Attachments (Terms of Use)
Xorg.0.log (92.34 KB, text/plain)
2009-10-08 12:24 UTC, g.puneet
no flags Details
xorg.conf (683 bytes, text/plain)
2009-10-08 12:31 UTC, g.puneet
no flags Details
dmesg (16.44 KB, text/plain)
2009-10-08 12:32 UTC, g.puneet
no flags Details

Description g.puneet 2009-10-08 12:23:40 UTC
Description of problem:

There are few issues I observed with r500. 

1. If user switches to 640x480 using xrandr and wants to come back or to some other resolution. It is not possible. System will always throw a black screen. 

2. If user switches to 1440x900 resolution using gnome-display-properties. system will safely come to said resolution but display will keep blinking. 

Version-Release number of selected component (if applicable): 5.3


How reproducible: 


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info: Attached are xorg.conf, dmesg, Xorg Log

Comment 1 g.puneet 2009-10-08 12:24:33 UTC
Created attachment 364099 [details]
Xorg.0.log

Comment 2 g.puneet 2009-10-08 12:31:50 UTC
Created attachment 364104 [details]
xorg.conf

Comment 3 g.puneet 2009-10-08 12:32:17 UTC
Created attachment 364105 [details]
dmesg

Comment 4 David Batson 2009-11-29 05:31:39 UTC
I believe I ran into the same problem.  I tried to change the default resolution on my T42 ThinkPad with the ATI mobility Radeon 9600 SXGA+ display using System > Preferences > Display.  Everytime I changed the resolution to from the native SXGA+ to XGA, I would get a black sceen.

I discovered adding nomodeset to the kernel line in /boot/grub/menu.lst resolved this problem for me.

<code>
default=0
timeout=5
splashimage=(hd0,4)/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.31.5-127.fc12.i686)
	root (hd0,4)
	kernel /vmlinuz-2.6.31.5-127.fc12.i686 ro root=UUID=5aa7eb85-7489-4d14-ba56-d9b7212d43d4  LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us rhgb quiet nomodeset
	initrd /initramfs-2.6.31.5-127.fc12.i686.img
<code>

Comment 5 Jérôme Glisse 2010-05-03 10:28:20 UTC
David you have different issue please open a bug on your own.

Comment 6 RHEL Program Management 2014-03-07 13:40:10 UTC
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.

Comment 7 RHEL Program Management 2014-06-02 13:08:36 UTC
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).


Note You need to log in before you can comment on or make changes to this bug.