Bug 52802 - iwlist causes core dump
iwlist causes core dump
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: wireless-tools (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-29 10:00 EDT by northup
Modified: 2014-03-16 22:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-10 23:39:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description northup 2001-08-29 10:00:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows 98)

Description of problem:
Tried to run iwlist and I got a core dump.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run iwslist
2.gasp at core dump
3.get upset
	

Additional info:
Comment 1 Bill Nottingham 2002-01-24 22:58:28 EST
Did you have any wireless cards installed - if so, what types?
Comment 2 Peter E. Popovich 2002-02-10 21:23:18 EST
eth0 is an Addtron AWP-100.

#ika:i686# iwlist eth0
Segmentation fault (core dumped)

reproducible with both:
wireless-tools-21-3 (rh 7.2 release)
wireless-tools-21-4 (rawhide)

(I'm not the original reporter of the bug.)
Comment 3 Ed Marshall 2002-03-27 15:35:29 EST
I can confirm the reported behavior. When running "iwlist <interface>", a core
dump is produced. "iwlist <interface> <command>" works as expected.

Really only a cosmetic problem, unless you've made iwlist suid root for some
strange reason. ;-)
Comment 4 Peter E. Popovich 2003-11-10 19:55:56 EST
methinks the bug has since been fixed.

#ika:i686# rpm -qf `which iwlist`
wireless-tools-26-1
#ika:i686# iwlist eth0
iwlist: unknown command `eth0'
#ika:i686# iwlist 
Usage: iwlist [interface] frequency
              [interface] channel
              [interface] ap
              [interface] accesspoints
              [interface] peers
              [interface] bitrate
              [interface] rate
              [interface] encryption
              [interface] key
              [interface] power
              [interface] txpower
              [interface] retry
              [interface] scanning

Note You need to log in before you can comment on or make changes to this bug.