Bug 528077 - No graphical boot (verbose text boot only) on ix86 live images 20091007+
Summary: No graphical boot (verbose text boot only) on ix86 live images 20091007+
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dracut
Version: rawhide
Hardware: i686
OS: Linux
low
high
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F12Beta, F12BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2009-10-08 20:59 UTC by Adam Williamson
Modified: 2013-01-10 05:31 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-10 00:39:38 UTC
Type: ---


Attachments (Terms of Use)

Description Adam Williamson 2009-10-08 20:59:34 UTC
At least since 20091007 - but possibly earlier, I haven't checked yet - the ix86 live images are not giving a graphical boot. Doesn't even give the console mode 'graphical' progress bar - you just get an old-skool verbose text boot. KMS does kick in, so the text console is in high resolution.

I have reproduced on two systems with completely different graphics chips, and James Laska has also reproduced on another system.

One of my test systems is x86-64 capable. If I boot an x86-64 live image, it works - perfect graphical boot. So this is specific to the ix86 images somehow.

Have tested with both 20091007 and 20091008 images, the public ones for 20091007 - http://alt.fedoraproject.org/pub/alt/nightly-composes/desktop/ - and warren's hosted on Delphi for 20091008 (ping warren for the address).

This is a beta blocker, I think.

Comment 1 Ray Strode [halfline] 2009-10-09 16:10:42 UTC
If this wasn't some weird transient bug that got fixed in a later compose, then would someone mind adding plymouth:debug to the kernel commandline and then attaching /var/log/plymouth-debug.log ?

Comment 2 Adam Williamson 2009-10-09 19:25:53 UTC
persists with 20091009, exactly the same behaviour with i686 image (from warren). IRC user henshaw (Oliver Henshaw) reported seeing the same bug with 20091007 desktop image, but he reported that the KDE spin from that date is OK. I had only tested desktop images to this point, will now test some other spins.

I'm doing the debug boot at present, will attach log shortly.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 3 Adam Williamson 2009-10-09 19:28:01 UTC
Even with plymouth:debug appended to kernel command line, no /var/log/plymouth-debug.log file is generated. /var/log/boot.log exists, but is empty.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 4 Adam Williamson 2009-10-09 20:43:03 UTC
Thanks to co-ordinated effort from warren, ray, and kevin fenzi, we pinned this one down: the problem is that the 'plymouth' package gets installed before the 'kernel' package where generating the desktop i686 image (but _not_ when generating the desktop x86-64 image, or the kde i686 image).

Now arguing about exactly why and exactly how to fix it.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 5 Bill Nottingham 2009-10-09 20:47:03 UTC
That shouldn't happen.

kernel has Requires(pre): dracut.
dracut has Requires: plymouth

Ergo, plymouth should *always* be installed before kernel.

CC'ing rpm gurus.

Comment 6 Adam Williamson 2009-10-09 21:06:01 UTC
whoops, i completely reversed that so it's very confusing. should read:

"the problem is that the 'plymouth' package gets installed after the
'kernel' package where generating the desktop i686 image (but _not_ when
generating the desktop x86-64 image, or the kde i686 image)."

thanks henshaw!

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 7 Jesse Keating 2009-10-09 22:01:11 UTC
Why can't we simply promote the Requires: plymouth to Requires(pre): (or Requires(post):) plymouth in dracut?  That should give rpm enough hints that we need both plymouth and dracut put down before kernel gets put down.

Comment 8 Ray Strode [halfline] 2009-10-09 23:08:32 UTC
Might work, okay with you Harald?

Comment 9 Jesse Keating 2009-10-10 00:16:19 UTC
I tested it, and it seems to work.  Hacky enough to get Beta/Final out the door (:

Comment 10 Jesse Keating 2009-10-10 00:39:38 UTC
Tagged for rawhide.

Comment 11 Harald Hoyer 2009-10-10 07:11:36 UTC
yep.. So all Requires for dracut will be converted to Requires(pre):

Comment 12 Adam Williamson 2009-10-10 14:43:33 UTC
just a quick thought - make sure to comment the change so it doesn't get reverted by someone who thinks it's a mistake...

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers


Note You need to log in before you can comment on or make changes to this bug.