Bug 528140 - [ALL Lang] TimeZone in Clock is Boston by default
[ALL Lang] TimeZone in Clock is Boston by default
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks: 795587 847386
  Show dependency treegraph
 
Reported: 2009-10-09 06:44 EDT by A S Alam
Modified: 2013-07-02 20:55 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 795587 (view as bug list)
Environment:
Last Closed: 2012-06-28 04:46:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot for s-c-date and gnome-clock (102.41 KB, image/jpeg)
2009-10-09 06:44 EDT, A S Alam
no flags Details

  None (edit)
Description A S Alam 2009-10-09 06:44:24 EDT
Created attachment 364235 [details]
Screenshot for s-c-date and gnome-clock

Description of problem:
After installation and setting Default Timezone Kolkata, Clock is showing Default Timezone (added by Default) Boston (after  Fresh installation).

Version-Release number of selected component (if applicable):
gnome-panel-2.28.0-2.fc12.x86_64
system-config-date-1.9.52-1.fc12.noarch
libgweather-2.28.0-1.fc12.x86_64

How reproducible:
Everytime

Steps to Reproduce:
1. fresh install with Hindi (hi_IN) locale
2. login with Hindi
3. Click on clock/Task Top-Right Side
  
Actual results:
Boston is added by Default

Expected results:
Either should be default for locale or s-c-date's Zone

Additional info:
Screenshot
Comment 1 A S Alam 2009-10-09 10:18:20 EDT
French (fr_FR) also showing Boston only Time zone in Clock
Comment 2 Matthias Clasen 2009-10-09 14:02:53 EDT
This is an intentional change; we think having some location selected is better than none at all; it makes the location support more understandable. Ideally, we will have a) geolocation support to automatically detect your location and b) firstboot support to select the default location.
Comment 3 A S Alam 2009-10-09 21:20:16 EDT
ok, that is good idea,
libgweather providing default region for each locale (for weather information),
Comment 4 Davide Cescato 2009-11-05 03:17:47 EST
I find the part of comment #2 after "Ideally" good. I disagree with the first part, though. Although I see the need of hinting the user about location support, I think that arbitrarily picking a location implies favoring a given city or country over all others and this may make some users feel discriminated. Politics may come at play here. Why a city on the East Coast and not on the West Coast? Why not a city in another country or continent?

So while the changes in comment #2 are being implemented, there should be no default location selected without any input from the user. 

If I remember correctly, there was no hinting about location support previous versions of Fedora anyway, so there is no regression in not providing any in Fedora 12.
Comment 5 Bug Zapper 2009-11-16 08:26:41 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Kieran Clancy 2009-11-25 03:47:17 EST
Why does this need to be during firstboot?

Fedora 12 asked for my timezone/location when I installed it by showing a big map and getting me to click on it. Why doesn't it use that? It logged it in my anaconda-ks.cfg file, and assumably stored that information someplace.

Also, I agree with Davide that having no default location is better than choosing one arbitrarily.
Comment 7 Dave Jones 2009-12-09 11:16:36 EST
I agree with Kieran.
I already selected Chicago from the map, so start there if you need a default.
What is the point of me choosing if it will be ignored?  Make the weather show in Chicago.  At least that is in the same time zone.

Taking it a step further-
I do not know if there is an equivalent of a zip code abroad (I admit this is probably something I should not be ignorant of) but maybe ask for that or give me a list of "weather locations" in the region of the "Chicago" selection I made earlier while doing the install.
Why is it giving me Chicago option just to select Boston on it's own?  
I really want my weather the be in St. Louis, MO (which is Chesterfield, MO in the weather list) in the first place.
Comment 8 Jens Petersen 2010-09-02 03:17:10 EDT
I agree with Dave seems better UX to default
to the selected system timezone location.
Comment 9 Ray Strode [halfline] 2010-11-30 13:22:47 EST
well part of the problem, I think, is the clock wants the user's actual location not timezone.  We only get timezone during install, so e.g., if a user lives in Boston they would pick New York as a timezone.

That means if we used that information we would still end up with the wrong location out of the box in the clock.

I think ideally anaconda would let the user pick location not just timezone and then we could make gnome-panel (or the shell in gnome 3) pick that up by default
Comment 10 Bruno Rocha 2011-03-08 09:44:47 EST
Any target dates for implementation?
Comment 11 Jens Petersen 2012-06-28 04:46:24 EDT
I can't reproduce the original report with F15.
So proposing to close this...

Anyway I guess the RFE is a gnome issue not anaconda.
Probably better to open a bug for that, upstream even.

Note You need to log in before you can comment on or make changes to this bug.