Bug 52817 - No "echo" when telnetting to Cisco router
No "echo" when telnetting to Cisco router
Status: CLOSED DUPLICATE of bug 52224
Product: Red Hat Linux
Classification: Retired
Component: telnet (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-29 13:21 EDT by Inger Karin Haarbye
Modified: 2007-04-18 12:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-30 10:21:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Inger Karin Haarbye 2001-08-29 13:21:59 EDT
Description of Problem:

I have a Cisco 677i ADSL-router, and I have to use telnet to configure NAT. 
With telnet from fairfax/roswell, I get no echo when I have telnetted to
the 
router and write commands - so I can't see what I'm writing. (Telnet to 
localhost is OK).

This was not a problem in Seawolf, so now I have downgraded my Roswell 
RC1-telnet to the telnet-0.17-10 -package from Seawolf, and it works again. 
Of course, you can do a lot of configuration even if you can't see what you 
are writing, but sometimes the result is unexpected.

As the "old" telnet-package still works, I think "something" has happened
to 
the new telnet?

Version-Release number of selected component (if applicable):

telnet-0.17-16
Comment 1 Pekka Savola 2001-08-30 06:59:38 EDT
Does 677i have a normal Cisco CLI or some fancy menu-driven interface?

telnet-0.17-18 on roswell2 works just fine for me (plain oldschool CLI
interface).

Could you try rebuilding telnet-0.17-10 and install it on your system (i.e., if
curses libs have changed..).  Similarly, if you still have a Seawolf box around,
does rebuilding -18 there work?

If feeling adventurous, you could also try commenting out the
"telnet-client-cvs" patch in the spec file.
Comment 2 Inger Karin Haarbye 2001-08-30 10:17:14 EDT
The telnet interface is not much fancy - just plain telnet.

Since last time I tested telnet on Seawolf, I had used up2date - and got the
same problem with the new telnet (0.17-18) as I have in the betas. 0.17-10 is
the only one of these that works for me. Rebuilding the rpms on Seawolf and
Roswell is not making any difference. 0.17-10 works on both systems, 0.17-16 and
0.17-18 does not work.

Commenting out "telnet-client-cvs" patch however gives me a "working" rpm!
Comment 3 Harald Hoyer 2001-08-30 10:21:36 EDT
Hmmm, will review the cvs patch
Comment 4 Harald Hoyer 2001-08-30 10:57:37 EDT

*** This bug has been marked as a duplicate of 52224 ***
Comment 5 Pekka Savola 2001-09-06 03:22:06 EDT
Patch posted to the other report.

IMO, this is a MUST-FIX issue.

(it won't come up that often as people don't use telnet much anymore, but if you
do...)

Note You need to log in before you can comment on or make changes to this bug.