This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 528180 - SELinux is preventing /usr/bin/yelp "execmem" access on <Unknown>.
SELinux is preventing /usr/bin/yelp "execmem" access on <Unknown>.
Status: CLOSED DUPLICATE of bug 507023
Product: Fedora
Classification: Fedora
Component: yelp (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:de4fa185f52...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-09 11:12 EDT by Andrew Vandever
Modified: 2009-10-27 19:42 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-27 19:42:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andrew Vandever 2009-10-09 11:12:11 EDT
Summary:

SELinux is preventing /usr/bin/yelp "execmem" access on <Unknown>.

Detailed Description:

SELinux denied access requested by gnome-help. The current boolean settings do
not allow this access. If you have not setup gnome-help to require this access
this may signal an intrusion attempt. If you do intend this access you need to
change the booleans on this system to allow the access.

Allowing Access:

One of the following booleans is set incorrectly: allow_execstack, allow_execmem

Fix Command:

Choose one of the following to allow access:
Allow unconfined executables to make their stack executable. This should never,
ever be necessary. Probably indicates a badly coded executable, but could
indicate an attack. This executable should be reported in bugzilla")
# setsebool -P allow_execstack 1
Allow unconfined executables to map a memory region as both executable and
writable, this is dangerous and the executable should be reported in bugzilla")
# setsebool -P allow_execmem 1


Additional Information:

Source Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
                              023
Target Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
                              023
Target Objects                None [ process ]
Source                        gnome-help
Source Path                   /usr/bin/yelp
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           yelp-2.28.0-1.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-22.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall_boolean
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31.1-56.fc12.i686.PAE #1 SMP
                              Tue Sep 29 16:16:16 EDT 2009 i686 i686
Alert Count                   4
First Seen                    Thu 08 Oct 2009 04:09:25 PM PDT
Last Seen                     Thu 08 Oct 2009 04:09:25 PM PDT
Local ID                      41b6d762-7253-486e-bcd6-a745e32a6b7d
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1255043365.456:24220): avc:  denied  { execmem } for  pid=2375 comm="gnome-help" scontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=process

node=(removed) type=SYSCALL msg=audit(1255043365.456:24220): arch=40000003 syscall=192 success=no exit=-13 a0=0 a1=2000 a2=7 a3=22 items=0 ppid=1 pid=2375 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=1 comm="gnome-help" exe="/usr/bin/yelp" subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  selinux-policy-3.6.32-22.fc12,catchall_boolean,gnome-help,unconfined_t,unconfined_t,process,execmem
audit2allow suggests:

#============= unconfined_t ==============
allow unconfined_t self:process execmem;
Comment 1 Matthew Barnes 2009-10-27 19:42:28 EDT

*** This bug has been marked as a duplicate of bug 507023 ***

Note You need to log in before you can comment on or make changes to this bug.