Bug 528181 - [abrt] crash detected in gvfs-obexftp-1.4.0-3.fc12
Summary: [abrt] crash detected in gvfs-obexftp-1.4.0-3.fc12
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gvfs
Version: rawhide
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tomáš Bžatek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:a80a1339a6334398d398c460200...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-09 15:15 UTC by Matěj Cepl
Modified: 2018-04-11 07:00 UTC (History)
5 users (show)

Fixed In Version: 1.2.3-13.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-13 02:29:36 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (4.80 KB, text/plain)
2009-10-09 15:15 UTC, Matěj Cepl
no flags Details
hopefully better backtrace (7.81 KB, text/plain)
2009-10-14 08:21 UTC, Matěj Cepl
no flags Details
manually created thread apply all backtrace (3.88 KB, text/plain)
2009-10-14 08:21 UTC, Matěj Cepl
no flags Details

Description Matěj Cepl 2009-10-09 15:15:14 UTC
abrt detected a crash.


How to reproduce
-----
1.
2.
3.


Comment
-----
Trying to copy a file to the "Browsing Bluetooth device" window

Additional information
======


Attached files
----
backtrace

cmdline
-----
/usr/libexec/gvfsd-obexftp --spawner :1.8 /org/gtk/gvfs/exec_spaw/3 


component
-----
gvfs


executable
-----
/usr/libexec/gvfsd-obexftp


kernel
-----
2.6.31.1-58.fc12.x86_64


package
-----
gvfs-obexftp-1.4.0-3.fc12


reason
-----
Process was terminated by signal 6

Comment 1 Matěj Cepl 2009-10-09 15:15:17 UTC
Created attachment 364260 [details]
File: backtrace

Comment 2 Tomáš Bžatek 2009-10-12 09:58:32 UTC
I don't see anything useful from the backtrace attached.

Comment 3 Matthias Clasen 2009-10-13 15:25:00 UTC
Matej, is this reproducible ? If so, could you try to install gvfs-debuginfo and get us a better stacktrace ?

Comment 4 Matěj Cepl 2009-10-14 08:21:06 UTC
Created attachment 364713 [details]
hopefully better backtrace

Comment 5 Matěj Cepl 2009-10-14 08:21:39 UTC
Created attachment 364714 [details]
manually created thread apply all backtrace

Comment 6 Matthias Clasen 2009-10-14 13:24:20 UTC
gvfsbackendobexftp.c:do_push has this:



     g_vfs_job_failed_from_error (G_VFS_JOB (job), error);
    }

  push_data_free (job_data);

  /* we called _query_file_info_helper (), so we need to invalidate the
   * cache, as a query_info () will be called on us after we return.
   */
  _invalidate_cache_helper (op_backend);

  g_vfs_job_succeeded (G_VFS_JOB (job));


Looks like there is a return missing after the failed_from_error call ?

Comment 7 Fedora Update System 2009-10-14 14:00:19 UTC
gvfs-1.2.3-13.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/gvfs-1.2.3-13.fc11

Comment 8 Matthias Clasen 2009-10-15 00:13:50 UTC
Tag request has been filed for F12

Comment 9 Fedora Update System 2009-10-15 22:38:59 UTC
gvfs-1.2.3-13.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gvfs'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-10532

Comment 10 Fedora Update System 2009-11-13 02:29:31 UTC
gvfs-1.2.3-13.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.