Bug 528184 - Rebase request for crash utility RHEL5.5 errata
Summary: Rebase request for crash utility RHEL5.5 errata
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: crash
Version: 5.5
Hardware: All
OS: Linux
high
medium
Target Milestone: rc
: ---
Assignee: Dave Anderson
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks: 5.5TechNotes-Updates
TreeView+ depends on / blocked
 
Reported: 2009-10-09 15:24 UTC by Dave Anderson
Modified: 2010-11-22 23:27 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
The crash packages are used to investigate live systems and kernel core dumps created from the netdump, diskdump and kdump facilities. With this update, Crash has been rebased to upstream version 4.1.2. For a complete list of bug fixes and enhancements, refer to the upstream changelog at http://people.redhat.com/anderson/crash.changelog.html
Clone Of:
Environment:
Last Closed: 2010-03-30 08:20:22 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2010:0230 normal SHIPPED_LIVE crash bug fix update 2010-03-29 12:36:20 UTC

Description Dave Anderson 2009-10-09 15:24:37 UTC
Description of problem:

The RHEL5.5 errata version of crash should be rebased to the current upstream
version of the crash utility.

It is far more efficient, and far safer, to rebase to the upstream version than
to attempt to selectively backport the patches required for the current set of
bugzillas approved for RHEL5.5.  Furthermore, the new features and other fixes
that have been applied to the upstream version make the tool significantly more
useful than the current RHEL5 version.

I can confidently state the above primarily because I am the original author,
the upstream maintainer, and the Red Hat maintainer of the crash utility.

As the upstream maintainer, one of my primary goals is, and always has been,
to maintain backwards-compatibility whenever new fixes or features are applied.
The risk of regression is less with a rebase than it would be with selective
backports because the RHEL5.5 bugzilla-required fixes are based upon the
state of the upstream version. 

It should be noted that nothing goes into the upstream version without my
approval, and my testing.  I perform all my testing on RHEL5 systems, and test
changes against a sample set of RHEL3, RHEL4, RHEL5 and upstream/Fedora kernel
crash dumps.

Furthermore, as a practical manner, the current RHEL5 version of crash needs
several updates to support upstream kernels.  That is an example of the kinds
of changes that are continually folded into the upstream version of crash as
the underlying kernel itself changes.  Given the onset of RHEL6, it only makes
sense that the RHEL5 version of crash can be used with the oncoming RHEL6
kernels.

And lastly, there have been several new debugging features added to the
upstream version that can only serve to aid our support and development
personnel in dealing with customer crashes more efficiently.  Details
regarding recent fixes, features and enhancements can be found in:

  http://people.redhat.com/anderson/crash.changelog.html

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 2 Dave Anderson 2009-12-10 14:16:04 UTC
MODIFIED: CVS Tag: crash-4_1_2-1_el5

Comment 6 Dave Anderson 2009-12-16 15:35:36 UTC
Technical note added. If any revisions are required, please edit the "Technical Notes" field
accordingly. All revisions will be proofread by the Engineering Content Services team.

New Contents:
The crash packages are used to investigate live systems and kernel core dumps created from the netdump, diskdump and kdump facilities.
						With this update, Crash has been rebased to upstream version 4.1.2. For a complete list of bug fixes and enhancements, refer to the upstream changelog at http://people.redhat.com/anderson/crash.changelog.html

Comment 8 errata-xmlrpc 2010-03-30 08:20:22 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0230.html


Note You need to log in before you can comment on or make changes to this bug.