Bug 528228 - Sat-sync with two --org options will use the second.
Summary: Sat-sync with two --org options will use the second.
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Satellite Synchronization
Version: 530
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Milan Zázrivec
QA Contact: Jiri Kastner
URL:
Whiteboard:
Depends On:
Blocks: 462714 533018
TreeView+ depends on / blocked
 
Reported: 2009-10-09 21:16 UTC by Brandon Perkins
Modified: 2014-07-04 13:26 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-04 13:26:01 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Brandon Perkins 2009-10-09 21:16:48 UTC
Description of problem:
Sat-sync with two --org options will use the second.

Version-Release number of selected component (if applicable):
spacewalk-backend-tools-0.5.28-34.el4sat

How reproducible:
Always.

Steps to Reproduce:
1. Setup Inter-Satellite-Sync.
2. Run satellite-sync including two orgs.
  
Actual results:
The content will only associate with the second org specified.

Expected results:
One of:
1) Warning that only the last org will be associated.
2) Preventing multiple orgs from being specified on the command-line.
3) Satellite sync should allow syncing content to multiple orgs:   Bug 528226 -  Satellite sync should allow syncing content to multiple orgs.


Additional info:

Comment 1 Brandon Perkins 2009-10-09 21:20:04 UTC
All related bugs that probably should be considered together when thinking about what to do:

Bug 528226 -  Satellite sync should allow syncing content to multiple orgs.
Bug 528227 -  Sat-sync with a different org it will remove the first.
Bug 528228 -  Sat-sync with two --org options will use the second.

Comment 2 Brandon Perkins 2009-10-09 21:31:59 UTC
Potentially of interest:

http://post-office.corp.redhat.com/archives/rhn-satellite/2009-October/msg00030.html

Comment 3 Milan Zázrivec 2009-11-04 17:31:03 UTC
Removing from under sat531-triage for the reasons stated in
https://bugzilla.redhat.com/show_bug.cgi?id=528226#c3


Note You need to log in before you can comment on or make changes to this bug.