Bug 528242 - HP Pavilion TX 2000 tablet doesn't work, wacom module major ABI version mismatch
Summary: HP Pavilion TX 2000 tablet doesn't work, wacom module major ABI version mismatch
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: linuxwacom
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Aristeu Rozanski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-09 23:53 UTC by Richard Schwarting
Modified: 2010-02-21 11:48 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-21 11:48:52 UTC
Type: ---


Attachments (Terms of Use)

Description Richard Schwarting 2009-10-09 23:53:52 UTC
Description of problem:
F12Alpha Live CD.  Tablet computer's tablet functionality doesn't work.  Seems to be detected in dmesg, but Xorg.0.log indicates the following error when loading the "wacom" driver:
"(EE) module ABI major version (4) doesn't match the server's version (7)"

That's part of a block of text like this, and I get a block like this for the tablet pad, eraser, etc:

(II) config/hal: Adding input device Wacom ISDv4 93 cursor
(II) LoadModule: "wacom"
(II) Loading /usr/lib/xorg/modules/input/wacom_drv.so
(II) Module wacom: vendor="X.Org Foundation"
        compiled for 1.6.0, module version = 1.0.0
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 4.0
(EE) module ABI major version (4) doesn't match the server's version (7)
(II) UnloadModule: "wacom"
(II) Unloading /usr/lib/xorg/modules/input/wacom_drv.so
(EE) Failed to load module "wacom" (module requirement mismatch, 0)
(EE) No input driver matching `wacom'
(EE) config/hal: NewInputDeviceRequest failed (15)

I have the tablet working in Fedora 11, but I compiled the wacom driver myself for F11 because the tablet wasn't even being recognised at the time.  If this gets fixed before F12 goes out, it'll be the first of three tablets I've owned that will work "out of the box" with Fedora :)  That's exciting. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Insert a Fedora F12Alpha Linux Live USB
2. Boot
3. Apply stylus to screen, in hopes of moving the cursor
  
Actual results:
Nothing, X doesn't respond to the stylus/tablet input.
The above ominous error can be seen in /var/log/Xorg.0.log

Expected results:
The cursor should respond and move.
No such error should appear.  

Additional info:

Comment 1 Dave Airlie 2009-11-05 05:52:57 UTC
still happen with the Beta or later releases?

Comment 2 Richard Schwarting 2009-11-05 08:25:15 UTC
Oh, forgot about this.  With the Beta, it does work fine now.  The touchscreen aspect doesn't appear to work, but the stylus/tablet functionality now does.

Now if only I could get my x41t's tablet to work by default :)

Comment 3 Bug Zapper 2009-11-16 13:28:39 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 4 Adam Pribyl 2010-02-21 11:48:52 UTC
    Thank you for the bug report. This particular bug was fixed and a update package was published for download for this Fedora release. 

    Please feel free to report any further bugs you find, or make further reports if this bug is not fixed after you install the update.


Note You need to log in before you can comment on or make changes to this bug.