This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 528283 - In Amarok the Browsers column is not selectable, meaning no music can be played
In Amarok the Browsers column is not selectable, meaning no music can be played
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
11
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-10 16:53 EDT by Patrick O'Callaghan
Modified: 2010-06-28 10:59 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 10:59:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot of the Amarok window (75.72 KB, image/png)
2009-10-10 16:53 EDT, Patrick O'Callaghan
no flags Details
Output from "amarok --debug" on the console. (90.91 KB, text/plain)
2009-10-11 14:06 EDT, Patrick O'Callaghan
no flags Details
Console output from a normal Amarok run. (3.52 KB, text/plain)
2009-10-11 14:07 EDT, Patrick O'Callaghan
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 210092 None None None Never

  None (edit)
Description Patrick O'Callaghan 2009-10-10 16:53:35 EDT
Created attachment 364353 [details]
Screenshot of the Amarok window

Description of problem:
I upgraded from amarok-2.1.1-4.fc11.x86_64 (which was working) to
amarok-2.2.0-2.fc11.x86_64 via yum from the Fedora updates repo and find it
essentially borked in that I can't select any music. None of the options in the
left-most Browsers column (Local Music, Internet, Playlists and Files) are
selectable when clicked on. I even tried removing .kde/shared/apps/amarok and
.kde/share/config/amarokrc to make sure I was starting afresh, but it makes no
difference.

I then logged in as a different user who had not previously used Amarok and
everything worked as it should.

Version-Release number of selected component (if applicable):
2.2.0

How reproducible:
Every time

Steps to Reproduce:
1.Install amarok 2.2.0
2.Run Amarok
3.
  
Actual results:
No Browser option can be selected, so Amarok is effectively useless.

Expected results:
Selectable options in the Browsers column.

Additional info:
I initially reported this to the KDE Bugs site (https://bugs.kde.org/show_bug.cgi?id=210092). The first response was that it appeared to be a packaging problem, so I'm repeating the report here.

Also, note on the attached screenshot that the columns have no headers. In fact I only know the leftmost column is called Browsers because I could see its name in the other user's instance. It's not visible here.
Comment 1 Patrick O'Callaghan 2009-10-11 14:06:21 EDT
Created attachment 364390 [details]
Output from "amarok --debug" on the console.
Comment 2 Patrick O'Callaghan 2009-10-11 14:07:12 EDT
Created attachment 364391 [details]
Console output from a normal Amarok run.
Comment 3 Patrick O'Callaghan 2009-10-11 14:09:01 EDT
Note the QT-related console messages in the attached files above.
Comment 4 Rex Dieter 2009-10-13 08:20:58 EDT
Discoverred onlist to be a theming bug, not an amarok one.
Comment 5 Rex Dieter 2009-10-13 09:09:14 EDT
I guess it was tracked down to qgtkstyle in use.
Comment 6 Patrick O'Callaghan 2009-10-13 09:48:48 EDT
Would QtCurve be the way to solve this more generally? I'm using gtk-qt-engine at the moment.
Comment 7 Kevin Kofler 2009-10-13 10:17:28 EDT
No. The way to solve this bug is to just fix QGtkStyle.
Comment 8 Glenn 2010-01-23 18:07:22 EST
Was there any final resolution to this one?  I've been experiencing exactly this problem through the last few updates.
Comment 9 Patrick O'Callaghan 2010-01-24 18:33:01 EST
As you can see above, the bug is really related to theming rather than to Amarok. The workaround for me was to switch to the Oxygen widgets, though the real culprit is qgtkstyle.
Comment 10 Glenn 2010-01-24 21:55:29 EST
Hmmm.  I've been using Oxygen all along, and still see this.  Let's see what some cycling of different options does for me.
Comment 11 Glenn 2010-02-21 12:00:47 EST
Yep, some jiggling of the widgets seems to have done the trick.  Thanks.
Comment 12 Bug Zapper 2010-04-28 06:47:16 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 13 Glenn 2010-04-28 08:21:45 EDT
The EOL is actually June 18. So more like 50 days?
Comment 14 Kevin Kofler 2010-04-29 05:01:29 EDT
Yes, the mass message was accidentally sent too early.
Comment 15 Bug Zapper 2010-06-28 10:59:56 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.