Bug 528318 - Netbeans should use system AA settings by default
Summary: Netbeans should use system AA settings by default
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: netbeans
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Victor G. Vasilyev
QA Contact: Fedora Extras Quality Assurance
URL: http://forums.netbeans.org/topic4102....
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-11 09:00 UTC by Michel Alexandre Salim
Modified: 2010-06-10 17:20 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-10 15:13:19 UTC
Type: ---


Attachments (Terms of Use)

Description Michel Alexandre Salim 2009-10-11 09:00:45 UTC
Description of problem:
Per the URL above, we should probably patch netbeans.conf to use system AA by default, by adding -J-Dawt.useSystemAAFontSettings=on

Without this, NetBeans looks rather terrible by default, esp. compared to Eclipse

Version-Release number of selected component (if applicable):
netbeans-6.7.1-1.fc12.noarch

How reproducible:
Always

Steps to Reproduce:
1. rm -rf ~/.netbeans
2. netbeans
3. Observe the fonts
  
Actual results:
Not anti-aliased, regardless of user's font config

Expected results:
Should follow whatever font setting the user desires

Additional info:

Comment 1 Bug Zapper 2009-11-16 13:30:02 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 2 David Kowis 2010-01-06 01:57:48 UTC
According to: http://forums.fedoraforum.org/showthread.php?p=1154640

And to my own testing installed locally on my box, adding: "-J-Dawt.useSystemAAFontSettings=on"
To the end of the netbeans_default_options in /path/to/netbeans.conf makes it behave nicely again.

Comment 3 Leif Gruenwoldt 2010-01-24 05:37:59 UTC
Possible duplicate of Bug 539971

Comment 4 Leif Gruenwoldt 2010-06-09 16:56:00 UTC
This seems to be fixed in F13.

Comment 5 Michel Alexandre Salim 2010-06-10 15:13:19 UTC
Would have been nice to hear from the maintainer, but as this is now the new upstream default, I'll close the bug.

Comment 6 Victor G. Vasilyev 2010-06-10 17:20:12 UTC
I guess the choosing of the best default options for a software/hardware configuration, including options of the fonts rendering, should be provided by a platform, but not by each particular application that will be run on the top of that platform. 
Moreover, I think, an application may have a facility to change the GUI options, but, by default, it should rely on the global options proposed by the platform that have been chosen by either the platform or a user due to some reasons.

So, in our case, the OpenJDK is the best place where this bug could be fixed. And, I glad to hear that it was solved in the OpenJDK.


Note You need to log in before you can comment on or make changes to this bug.