Bug 52832 - Man pages crashes Savage4 system running 7.2 RC1
Man pages crashes Savage4 system running 7.2 RC1
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-29 15:22 EDT by Wendy Hung
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-04 15:17:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wendy Hung 2001-08-29 15:22:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT)

Description of problem:
This problem seems to involve an incompatibility between IBM video 
controllers(S3 Savage4 and S3 Savage4 Pro) and the video driver probed by 
Anaconda which uses hardware acceleration. When viewing the XF86Config-4 
that is created by Anaconda,  the following comment is included in the 
Savage Device section:

#No known options

By adding the following line:
option "no accel"
hardware acceleration is disabled and prevent the server from further 
crashing.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install 7.2 RC1 on IBM xSeries x330 and for video configuration select 
S3 Savage4 (highlighted by default),  8MB Video Memory and 1024x768 
Resolution. 

2.After installed, start up Gnome as either root or a normal user (both 
tested).

3. Click on Main Menu --> Programs ---> Help Systems.
Click on Man Pages in the Help Index section.
Click on either of the following Man Pages - File Formats.  Or any of the 
Man Page books- 4, 5, 6, 7, 8.
	

Actual Results:  The system will hard hang.  Manual reset and cold reboot 
required.


Expected Results:  Man pages displayed.

Additional info:

Also seen on other xseries servers (x232, x300, x330, x342) with either S3 
Savage4 or S3 Savage4 Pro onboard video chipsets running RH 7.2 RC1 and an 
x200 running RH 7.1.
Comment 1 Trond Eivind Glomsrxd 2001-08-29 15:38:08 EDT
This isn't caused by a bug in the man-pages - reassigning to XFree86.
Comment 2 Mike A. Harris 2001-09-01 07:24:55 EDT
The savage driver has just been updated.  Please try the new
XFree86 release found at:

ftp://people.redhat.com/mharris/testing/bleeding-edge/XFree86
You'll want to get the XFree86-4.1.0-1.1 release.
Comment 3 Wendy Hung 2001-09-04 15:17:18 EDT
Fixed in XFree86-4.1.0-1.1
Comment 4 Wendy Hung 2001-09-04 15:28:39 EDT
Will XFree86-4.1.0-1.1 be in RH 7.2 gold?

Note You need to log in before you can comment on or make changes to this bug.