Bug 52832 - Man pages crashes Savage4 system running 7.2 RC1
Summary: Man pages crashes Savage4 system running 7.2 RC1
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-29 19:22 UTC by Wendy Hung
Modified: 2007-04-18 16:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-04 19:17:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Wendy Hung 2001-08-29 19:22:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT)

Description of problem:
This problem seems to involve an incompatibility between IBM video 
controllers(S3 Savage4 and S3 Savage4 Pro) and the video driver probed by 
Anaconda which uses hardware acceleration. When viewing the XF86Config-4 
that is created by Anaconda,  the following comment is included in the 
Savage Device section:

#No known options

By adding the following line:
option "no accel"
hardware acceleration is disabled and prevent the server from further 
crashing.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install 7.2 RC1 on IBM xSeries x330 and for video configuration select 
S3 Savage4 (highlighted by default),  8MB Video Memory and 1024x768 
Resolution. 

2.After installed, start up Gnome as either root or a normal user (both 
tested).

3. Click on Main Menu --> Programs ---> Help Systems.
Click on Man Pages in the Help Index section.
Click on either of the following Man Pages - File Formats.  Or any of the 
Man Page books- 4, 5, 6, 7, 8.
	

Actual Results:  The system will hard hang.  Manual reset and cold reboot 
required.


Expected Results:  Man pages displayed.

Additional info:

Also seen on other xseries servers (x232, x300, x330, x342) with either S3 
Savage4 or S3 Savage4 Pro onboard video chipsets running RH 7.2 RC1 and an 
x200 running RH 7.1.

Comment 1 Trond Eivind Glomsrxd 2001-08-29 19:38:08 UTC
This isn't caused by a bug in the man-pages - reassigning to XFree86.

Comment 2 Mike A. Harris 2001-09-01 11:24:55 UTC
The savage driver has just been updated.  Please try the new
XFree86 release found at:

ftp://people.redhat.com/mharris/testing/bleeding-edge/XFree86
You'll want to get the XFree86-4.1.0-1.1 release.


Comment 3 Wendy Hung 2001-09-04 19:17:18 UTC
Fixed in XFree86-4.1.0-1.1


Comment 4 Wendy Hung 2001-09-04 19:28:39 UTC
Will XFree86-4.1.0-1.1 be in RH 7.2 gold?


Note You need to log in before you can comment on or make changes to this bug.