Bug 528352 - glabels can't read saved projects
Summary: glabels can't read saved projects
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: glabels
Version: 11
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Peter Gordon
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-11 14:24 UTC by Ralf Corsepius
Modified: 2009-12-18 04:40 UTC (History)
2 users (show)

Fixed In Version: 2.2.6-1.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-18 04:24:43 UTC


Attachments (Terms of Use)
Patch to change glabels use XML_PARSE_HUGE (816 bytes, patch)
2009-10-12 06:51 UTC, Ralf Corsepius
no flags Details | Diff

Description Ralf Corsepius 2009-10-11 14:24:08 UTC
Description of problem:
Glabels can't read saved projects.

Version-Release number of selected component (if applicable):
glabels-2.2.5-1.fc11.x86_64

How reproducible:
Always

Steps to Reproduce:
1. launch glabels
2. Create a project containing a jpg
3. save project
4. exit glabels
5. launch glables and try to open previously saved project
  
Actual results:
# glabels test1.glabels 
/home/user/tmp3/test1.glabels:129890: error: xmlSAX2Characters: huge text node: out of memory
DBcJDxcIERkKDhcGEBkIFBwHFx8KGSEKGyMMHSYLICYMIScLIycMJCgNIycMICYMHiQKHyQNICUO
                                                         ^
/home/user/tmp3/test1.glabels:129890: parser error : Extra content at the end of the document
DBcJDxcIERkKDhcGEBkIFBwHFx8KGSEKGyMMHSYLICYMIScLIycMJCgNIycMICYMHiQKHyQNICUO
                                                         ^
glabels-Message: xmlParseFile error


Expected results:
Function.

Additional info:

Comment 1 Ralf Corsepius 2009-10-12 06:49:34 UTC
This bug seems to be caused by libxml2 having changed its behavior:
c.f.: http://bugs.php.net/bug.php?id=49660

Adding XML_PARSE_HUGE to the places where glabels opens xml-files seems to fix this issue. AFAIS, already has applied a corresponding fix in their git repository.

Comment 2 Ralf Corsepius 2009-10-12 06:51:35 UTC
Created attachment 364430 [details]
Patch to change glabels use XML_PARSE_HUGE

This patch is a back-port to 2.2.5 of what upstream has in their git repository.

Comment 3 Ralf Corsepius 2009-10-29 05:05:34 UTC
Ping?

Comment 4 Ralf Corsepius 2009-11-21 10:57:17 UTC
Bug is also present in FC12.

Provided your non-responsiveness, I am going to launch an AWL process against
this package's maintainers: pgordon and jspaleta.

Comment 5 Jef Spaleta 2009-11-24 07:38:24 UTC
I apologize, I lost this report got lost in a series of abrt reports.  

If you are volunteering to take up co-maintainership I'm more than happy to give you rights to it. Otherwise I'll be able to get this patch into a package on Thanksgiving.

-jef

Comment 6 Ralf Corsepius 2009-11-24 07:56:58 UTC
(In reply to comment #5)
> I apologize, I lost this report got lost in a series of abrt reports.  
Thanks for responding. So at least you haven't got lost ;)

Makes me wonder about Peter ... I will continue the AWOL process against him, shouldn't he show up, really soon.

> If you are volunteering to take up co-maintainership I'm more than happy to
> give you rights to it.
Thanks for the offer, but I think it doesn't make much sense for me to co-maintain this package, because I am just an "occasional user" who happens to be using glabel to author DVD/CD labels and who is bitten by a nagging bug.

Apart of this, my "proven-packager privileges" already would allow me to apply the patch, ... however, I don't consider this bug to be critically enough to justify intercepting into "proper package maintenance".

> Otherwise I'll be able to get this patch into a package
> on Thanksgiving.

FWIW: There has been a new release. AFAICT this release has this bug fixed, however, I haven't given it a try, yet.

Comment 7 Jef Spaleta 2009-11-26 05:52:52 UTC
I have version 2.2.6 built for F11 and F12 as koji scratch builds.  Can take one of these builds for a spin and see if its solves the issue for you on your 64bit system.
F-11
http://koji.fedoraproject.org/koji/taskinfo?taskID=1831459
F-12
http://koji.fedoraproject.org/koji/taskinfo?taskID=1831498


its not building against rawhide however which is odd.

-jef

Comment 8 Jef Spaleta 2009-11-26 06:51:15 UTC
Now that's odd.  Peter DID apply the patch you sent in to the devel tree but didn't fire off builds.  Oh well.  I'll sort this out.  If you can test the 2.2.6 build on 64bit  I'd appreciate it.

-jef

Comment 9 Fedora Update System 2009-11-28 00:55:51 UTC
glabels-2.2.6-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/glabels-2.2.6-1.fc12

Comment 10 Fedora Update System 2009-11-28 00:55:57 UTC
glabels-2.2.6-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/glabels-2.2.6-1.fc11

Comment 11 Fedora Update System 2009-12-01 04:36:42 UTC
glabels-2.2.6-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update glabels'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12428

Comment 12 Fedora Update System 2009-12-01 04:46:42 UTC
glabels-2.2.6-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update glabels'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-12456

Comment 13 Fedora Update System 2009-12-18 04:24:38 UTC
glabels-2.2.6-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2009-12-18 04:40:32 UTC
glabels-2.2.6-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.